New to Blender Game what causing this with alpha/texture/color?

OK, just starting playing around with blender game a few days ago. Any ideas on what is causing this issue? If I hit play with scene “level 1” it works fine ,but if I start from scene “main menu” and go into level one I run into this problem. I bout figure out it is picking up the diffuse color(see the diffuse color on level 1) Not sure how to fix it.

This is running from the main menu scene. Where it seems to be picking up diffuse color around crosshairs.


This is running from the level 1 scene. Doesn’t have light blue around crosshairs.


Check both scenes are in the same draw modes:

  • glsl vs multitextured

Yeah that was one thing I look at and they are both the same.Figured it has to do with some setting on the the main menu level ,but still haven’t found it if that’s the case. I did end up solving my problem by DerpGoose’s response in this thread. https://blenderartists.org/forum/showthread.php?393633-Blender-Game-Engine-Alpha-(bug-)-plz-halp&highlight=alpha%20game%20engine Still makes no sense why playing from level one it worked.

It might be you have a mesh without material. This was causing material trouble in the past.