Newb question about keyframing multiple bones at once. Can I?

I’m animating a bone chain. I select all the bones, set my pivot points to individual origins, then rotate them together and set a key. It only keys the first bone in the chain and snaps the rest back to their old position once I change frames. The only way I can see to keyframe all the bones is to select and key each one by one. Even auto key doesn’t work here.

Is there a way to select a whole group of bones and animate/key them at the same time?


This problem looks strange because I often create keyframes for multiple bones a tonce.
Is there any “special thing” on those bones ?

Im not doing anything special that i know of. Simple bone chain, no constraints. Your saying that i should be able to select multiple bones in an armature, and when i set a key using “i” it should set a key for all selected bones? Thats how it should work, but thats not working for me. Auto key isnt working for child bones either.

My question may be stupid but are you sure you are in pose mode when you try to create some keyframe ?

Yep! I’m in pose mode and I can manually set keyframes on one bone at a time. Or auto key one at a time. If I have multiple objects selected it only keyframes the first bone in the chain.

Ok, I just tried this on a simple 5 bone chain, nothing else in the scene.

Grab all bones at once, set pivot to individual objects and rotate them, then set a key. Go to a new frame and rotate them again, again, setting a key. As soon as you leave the frame, all your child bones will snap back to their old initial position. Is this a bug, or can blender just not key multiple objects at once?
I’m using the latest stable blender from

Are you trying to use Auto Keyframing? It is the only way I can reproduce what you are experiencing. If I use I to insert a keyframe on all selected bones it works every time. If I try and just rotate them all with auto keyfaming on it only records the first bone.

Ok, that’s what I’m getting now too. Inserting with “i” is working for me now. Not sure what I was doing wrong, but auto keyframing definitely doesn’t appear to be working with a child heirarchy. Do you think that is a bug? Should we log it?

Oh I haven’t paid attention that you used auto keyframe.
Actually I don’t use this feature, I prefer creating my keyframes with “I” but I have just tried to keyframe a bone chain with autokeyframe and indeed it doesn’t work as has Richard Culver said (however it works with “I”).
Indeed I think it could be a bug.

Well I am not sure about bug or unimplemented. (on TO DO list) Definitely should be looked into/reported because it works in 2.49b. I just checked.