Newbie: Gus is full of traps


I am struggling to complete the Gus tutorial. As many, I fell in the ‘BKEY doesn’t select hidden vertices before Extrude’ trap, and found the solution here (except that in version 2.40, the ‘Limit Selection’ button is nowhere to be found).

After that, when creating the four spheres to make the mouth, the tutorial instructs to use the Spin Dup button. Well, it didn’t work: I got a “Wrong Window” error. I don’t know why, but I had split my main window in four earlier on with the four main views (front, top, left, camera). I had to switch the latter three to something else before Spin Dup worked.

Later on, I could not assign different materials to each sphere (eyes, mouth, buttons). It turns out that I created them all in Edit mode, and they all made up one single object. It took me forever to find about the seParate function.

Now I have a strange issue with rendering (very end of part I): the end result is very blurry, and strangely, while rendering, the rendering window displays a very narrow (vertically) image, which looks sharp enough. At the end of the rendering process, the image is blown up vertically, yielding a blurred result. Maybe I touched some setting somewhere, but I can’t find what. I tried to change about everything in the Format pane, with no result.

If I create a new document, the startup cube renders just fine, without that strange behaviour.

I have a screen shot of the rendering window during the rendering process that displays the phenomenon. I don’t know how to post it however. So I put it up on my web page at I could even make a movie if needed.

This is on a Macmini, 1GB RAM. MacOS X.4.4



Even not in Edit Mode?

Anyway, if you do good old gus in 2.4 you will run into many problems. It’s after all not bad for a tutorial, but for a beginner with the wrong blender version it’s nearly useless.

So I guess someone will have to update it.

BTW: you have switched on “fields” in the render panel. Switch it off.

The limit selection button is in 2.40. It appears in edit mode and is here:

PS: your link is broken, you had an extra dot in it.

Here it is

It could be blurry because you have antialiasing set too high possibly?

If it looks blurry in the render window then that could be it but you are also exporting as a jpeg which does introduce artifacts the image. I tend to use png format which can be chosen from the preferences menu.

I downgraded the version the tutorial was written for because I could then grasp the basics and have only just moved to 2.40. For what it’s worth, you have done really well considering the differences between the two versions!

Thanks to soylent_gr: that was it: the fields mode was on in the render pane.

It was not due to JPEG. I actually generated PNG, and converted to JPEG only for my web site. And in any case, JPEG artifacts is not blurring.

Sorry about the broken link. Actually the forum software made the link. I only typed pure text.

I found the Limit selection button. I missed it, I don’t know how. Thanks for your screen shot. How do you include a picture in a forum posting?

I decided to try and continue with version 2.4. As a challenge. Struggling makes the learning process that much more effective! Additionally, I will document all the pitfalls for others.

Thanks a lot to you all


jd, it is blurry actually. Hurts my eyes to look at it.

For images, I use Imageshack to upload them as they provide you with a load of links for posting images. One of them gives you the thumbnail view for forums link which works perfectly on here.

Why not use that to post up an image of your render settings window so we can compare them?

I’d have to congratulate you. You seem to have gone about this in the right way. You struggled with it, looked for answers, found some, missed others then sought clarifications. That is the essence of learning Blender and it is the price we pay for using a powerful but completely free product.

Bluriness: it seems fields was the answer to your problem (I would never have guessed it) but the jpeg did make it worse by introuducing a lot of artifacts around the perimeter of gus. I too assumed this was the blurriness you were worried about.

The Limit Selection button appears only when you have solid mode turned on. My best guess would be that while sorting through various options you turned wire mode on then later looked for the button which was no longer there. So for future reference, either select hidden vertices by working in wire mode or by turning limit select off in solid mode.

With the SpinDup error: I wonder if your mouse cursor was hovering in the wrong place when you tried it? I don’t use it and can’t really remember how to apply it but I can tell you Blener is very window sensitive and few things will work as expected if your mouse is over a different window.

The separate feature doesn’t seem to be mentioned enough. For other reading this, you can select a vbertex of one mesh in edit mode, press Ctrl-L to select connected vertices (eg. a whole button) then P-Key to separate this mesh from other parts of the mesh (eg. all the other buttons. This then becomes a separate object.

BTW, you can apply different materials to one mesh in Edit Mode too. So you could have left your buttons together then applied different materials to each. Search for multiple materials for more on this. It’s a bit complicated but it works well.

It’s good to see you’ve got it all working under OS10.4.4. I’ve stuck with 10.3.9 partly because there had been lots of problems with Blender in the 10.4.3.

Also note that if you’re now working on the armature part of the tutorial - all that’s changed too. Welcome to Blender :wink:

Yes Jean-Denis did very well with the Gus tutorial, and his post brings up a theme from another recent thread. That newbies need help with Gus, there are minor gaps in the original tutorial, then to make things all the more confusing, there have been a number of changes to Blender.

The worst thing is that sells “The Official Blender 2.3 Guide” with a beginning tutorial that cannot be completed correctly as described. An enthusiastic newbie (like me :wink: will buy the book to show support for the project, only to be unnecessarily frustrated. It is almost a cruel joke played upon people trying to help the cause.

I strongly recommend that someone create a two or three page correction, at the very least for the Gus tutorial, with a list of internet links for more updates, and include it with each copy sold.


That’s it: i managed to do it my GUS is animating fine. The second part, with the armature has overall a few less SNAFUs than part 1:

1- Contrary to the manual, bone chains are not automatic. This means two things:

  • When adding only one bone, as in the arms, I had to Rotate (RKEY) the bone as a second step to position it correctly

  • When adding bone chains as in the the legs, I had to Extrude (EKEY) the bone to add another linked bone. This is all perfectly counter-intuitive! (that was a tough one: initially I managed to do it in a more complex way, by creating unlinked bones, then joining and parenting them).

2- When Inserting (IKEY) the bone position is a frame, it is very important for all the bones to be selected. The tutorial mentions it, but I had missed it for some reason, and my animation didn’t work.

Thanks for all the help. I will upload the results to my web site (, where the images and movie will show up. I will try to avoid JPEG.


Answers to answers:

  • The limit to button only shows up in solid mode, not wire mode. This why I initially could not see it. Let me voice here my opinion that in general, REMOVING user interface items when they are not applicable is usually not a wise design decision. It is far better to leave it there and disable it. Additionally, the mouse tip that shows up when hovering on it can tell why it is disabled.

  • SpinDup error: the mouse cursor has only one place to be: the button window, as it used by clicking on a window. I don’t know much, but this may be a bug.


I can also mention a problem I faced, though it is not related to the tutorial, but to Blender in general.

When I first launched Blender, it did not work: the window was completely screwed up (see my web site for a sample).

After a struggling a while, it turned out there was no problem if I shrank the window to a small enough size, or if I switched my screen to thousands of colours. The problem only occured in millions of colours with a large window (my screen is 1920x1200).

So I ran the tutorial in thousands of colours (16 bits).

I suppose the problem is with the amount of VRAM I have: I run on a Macmini, which has a Radeon 9200 VPU with 32MB of VRAM only.

For the record, I run under MacOS X 10.4.4.


I suppose the problem is with the amount of VRAM I have: I run on a Macmini, which has a Radeon 9200 VPU with 32MB of VRAM only.

I don’t think it’s the amount of VRAM, but the graphics card. ATI cards are known to have problems with Blender. Search the forum for more info on this.

After a struggling a while, it turned out there was no problem if I shrank the window to a small enough size, or if I switched my screen to thousands of colours. The problem only occured in millions of colours with a large window (my screen is 1920x1200).

I suspect this is still the Mac OS10.4.x OpenGL bug. I haven’t really followed the threads because I’m still using OS10.3.9 but as I understand it, Apple dropped support for some OpenGL features that Blender uses to draw the UI. Doing cetain things apparently caused Blender to behave better and these are probably the solutions you mention above.

The fault lies with Apple, not Blender, and it is likely other apps that use these OpenGL features are also broken in 10.4.x. Apple have been informed but since you have 10.4.4 (latest) and are still having problems, it seems Apple might still be deaf to the issue. Seems I’ll be keeping my hard-earned money in my pocket until Apple sort this out.

I am not sure the problem source lies in Apple dropping support for some call, for how would you explain that everything is OK in thousands of colors AND also in millions of colors if the window is small enough?

It might be an OS bug, one that would show up only in millions of colors AND with large windows. Such a bug might be VRAM related. Or not.

Since you run 10.3.9, can you confirm you can have very large Blender windows (like 1900x1100) without problem? How much VRAM do you have?



It is a ram issue,

regarding GUS tutorial - I’m having someone on the docboard redo it this week - so if you could have a look at it next weekend to make sure all changes have been addressed that would be good.


I think that the use of mirror modifier and erase edge loop could be introduced in Gus tutorial.
With mirroring you have to model only 1/4th of Gus due to its symmetry. When the model is ready, all the user has to do is to hit apply at mirrors and remove the two additional loops that were created due to mirroring.

The buttons could be done by using dupliverts but that’s overly complicated for the tut? Perhaps it could be an alternative?

Also I think that perhaps the envelopes could be introduced in the animating Gus as an alternative.

My screen is only 1280x1024 and as it turns out I’ve been running at thousands of colours. I’ve changed it back to millions and will see how it goes.