Newbie problem ???? Animation flickers.... Material ?? Light ???


I have now played one week with Blender and must say that this Forum helped me lot more than all the tutorials i’ve read. Til now i’ve found always a answer to my questions by searching this forum.

Now i have created my first complex object and an animation with it. But no matter what i’ve tried i cant get rid of that flickering on two of the meshes. i tried all all of the material switches and tried all the changes to the light… nothing helped… but see for yourself…

My first Blender Object and animation

The second question i have … When i have just one light source and i turn it to cast shadows… some of my materials get messed up. I have get around that with having 3 lightsources and only one cast shadows… but that can not be the answer… or???

here the example of what i mean…

First with the second light source not casting shadows

and here is the second… when i turn cast shadows on

I hope someone can point me in the right direction…

Greetings from germany

From a fellow newbie(3 days)::

I noticed a similar effect when I rendered with shadows with a lower than 8 OSA setting in the scene window. If at 4 or 2, it would render the shadows a little bit grainy, which wasn’t so happy.

Hi Okiphia…

in my case its not the shadows that are grainy, its the object that casts the shadow… i tried the OSA setting (rendering and Full OSA for the material)… no change

I have found that flickering problems are generally with the geometry, not the lighting.

Try removing double verticies on your model and make sure you don’t actually have dual geometry exactly on top of each other. You also may try ReCalculate normals as well.

It’s perfectly overlapping faces, in other words, bad modeling, you probably should go back and redo those parts of the model.

try rem doubles in edit mode, you may not have to do much work (if it is overlapping faces)

Yeahhh… to remove the double verticies did the trick… but how did they get there in the first place ??? i made a cube, formed it, copied it… and so on… what made some verticies double…???

I just found that overlapping objects make a shadow problem especially when they are parented and hard to see in the outliner windows

It’s a fairly easy mistake to make when you’re relatively new to modelling. You may have duplicated all the verts at some point by accident and not realised it (e.g. in edit mode having everything selected and pressing shift-d and clicking again so fast you dont realise you’ve actually duplicated it at all) or something like that. It happens occasionally, just learn from it and watch out in future.

shift-d and right click (duplicate, but cancel transform after duplicate) or E and right click (extrude and cancel trasform after extrude)- it’s easy while modeling fast to press a wrong button and then say oh shit! cancel, and leave a few extra verts around. Most people learn to avoid it by reflex eventually, but a rem doubles every now and then can’t hurt (well, it can, if you have the threshold set to high or you have verts really close to each other that you don’t want to delete- or if you have doubled verts on purpose)
EDIT- I just realized Six Ways already answered the question, sorry!