Newbie Shading question.

So… can someone tell me what’s wrong with my shading? And how to fix it? Thanks.

Select the offending objects, and add an EdgeSplit modifier.

Whats happening here is that you have the objects set to render as “smooth” this means blender tries to adjust the normals on a face so the light is reflected in a smooth way from face to face. The problem you are having is that this method isn’t made to smooth around sharp corners, (something around 60 degrees or more becomes to much for it to look good, but that really depends on the situation.) there are several ways to fix this, one is as mentioned above to use the edge split modifier, but you can also just turn off the set smooth option altogether, which as long as you don’t have and curved surfaces will be the fastest option. another way to fix this is to increase the number of faces around the sharp edges, this will make the faces that warp there normals to be much smaller and thus not make such a large area of bad shading.

Hope that short little bit made sense, for more info search for things like “normals” on this site and the blender wiki’s.


Thanks a lot for the reply, the edge split modifier did the trick.