Newbie: Texture refuses to influence alpha

Hello,

I want the plane to be transparent according to the tree outline texture.
But it is impossible.

Ticking Influence -> Alpha does not do anything.

Meanwhile,
Ticking influence -> Color or Normal, works Ok (see example below for Color).

I suppose I am missing something obvious, but what could it be ?

[ATTACH=CONFIG]217882[/ATTACH]

[ATTACH]217883[/ATTACH]

[ATTACH=CONFIG]217884[/ATTACH]

Example: it works for color. If I tick alpha nothing changes.

Enable Transparency in Material settings and slide Alpha value under Z Transparency to 0. And if you want only tree outline, you’ll need to invert your texture colors. :slight_smile:

In the material tab, you need to turn on Transparency, and set it to ZTransparency. Set the Alpha here to 0. Then in your textures panel enable affecting Alpha, you may need to check RGB to Intensity if your mask isn’t a greyscale image. (it didn’t appear to be packed in the blend) Black areas will be transparent unless you check the Negative box next to Blend mode.

Thanks guys!

It kind of worked, but the plane drops a full shadow behind it. Could it be that it drops only the shadow of the tree ?
(actually this is what I am trying to achieve)

Yep it needed to check RGB to Intensity. The tree image is not a grayscale image. How do you define “grayscale image” ?
Would a jpg that only contains grayscale colors, qualify for a grayscale image ? Or do I need specific format ?
I have Photoshop and Gimp.

Thanks again!

It kind of worked, but the plane drops a full shadow behind it. Could it be that it drops only the shadow of the tree ?
(actually this is what I am trying to achieve)
For the objects that are receiving the shadow, enable the ‘Receive Transparent’ tickbox in their Material / Shadow settings.
Ensure your lamps are using Raytrace Shadows. You will see the result when rendered, not in the viewport

Attachments



You guys are life savers thanks !

Usually it’s a matter of setting the colour mode before (but in some programs while) saving. In GIMP, go to the Image menu > Mode > choose Grayscale. Not sure about PS, but I presume there is a similar method. Just working with grey’s is not the same. A greyscale format is only saving the value information of the image. I think that not all image formats can be greyscale only, but jpg can.