Newly Created Objects Are Invisible

Suddenly and inexplicably, I can no longer see the objects I create. :spin:

I can see the objects in the outliner, taunting me. The little “eye” is on. I’ve tried “alt + h” to unhide all.
The 3D cursor is at the origin when I create the objects, and the objects’ location reads 0,0,0. They’re not hiding inside anything else in the scene as far as I can tell.
I’ve tried using the “.” shortcut with the object selected in Outliner view but nothing happens; the view doesn’t shift.
There’s nothing on any of the other layers; I’ve tried selecting them all with the “~” key.
I reset the interface to factory default.
…And nothing!
The problem seems to be specific to the attached .blend file. The other .blend files on my computer work fine.

Anybody got an idea as to what might be causing this? I’m totally stumped!

Thanks in advance! :eyebrowlift:
Skyfire1.blend (155 KB)

I’m stumped … I was able to open the file and add a new cube, no problem; so I don’t think it’s an issue with that particular file.

There is a problem with your scene, notice you have no layer toggles at all?

Here is a solution:
Open Blender.
Append your entire scene into this new file.
Switch to that imported Scene.
Then select the Cylinder in the Outliner and press F7.
You will see that the Cylinder layers buttons are all turned off.
Turn on the Layer #1 for the Cylinder and it will appear back in your scene.

Thank you very much! That worked perfectly! :yes: I’m so glad to have that figured out…
And thanks for giving it a shot, Danalou. :slight_smile: