Ngons Shading Issue

Hi all,

I am trying to follow this guy’s tutorial on making a pistol:

However even though I do the same thing he does, shading on mine looks different. I also enabled auto smooth 60 degrees and made sharp edges but it doesn’t look the same.

How this guy’s pistol is looking flawless in terms of shading despite the ngons? What am I missing?

Wireframe screenshot pls. Now I think you put in there tooo much geometry. Keep your poly-count as low as possible.

Here the geometry is pretty low also the surface is flat and auto smooth enabled. Why shading looks bad?

This is wireframe

Try the wieghted normal modifier.

GPU-card ALWAYS triangulate geometry. Even if you have n-gon in Blender\3DSMax\Maya ect it does not matter. This is not “bad” - this is how it is. You see on you screen two things:

  1. How your geometry auto-triangulated to view in OpenGL-display
  2. You need to learn how to control normals in n-gons (on flat furfaces! - check this first, because in sub-d modeling this is always bad to have non-quads on non-flat surfaces)