Ngons visible in Ortographic Lens Type

Does anybody know if you can avoid this shading issue? This is the difference between having a mirror with some boolean holes in a flat surface using perspective and ortographic lens type.

HDRIs don’t work in orthographic view, they’re reliant on perspective and orthographic view has an infinite perspective

1 Like

The Weighted Normals modifier should fix that quickly enough.

I tried that already and it doesn’t fix the issue. The issue comes from the camera and the way it sees things. That picture is actually in perspective. You can try to add a camera and change it to orthographic. I’ve even tried using a data transfer node and it won’t solve the issue. It modifies the way the reflection looks but it doesn’t solve it.

I don’t think that it’s the issue I am having. Even if the HDRI isn’t properly reflected the issue comes from how the camera sees ngons shading. I’ve also tried adding a simple cube and the cube reflection has the exact same issue.

This is how it reflects a cube with weighted normal node at 50.

And this is at 100. Still not perfect.

I was able to recreate your problem. I fixed it by jumping into edit mode, and subdividing the cube three times to give it more geometry to work with.

Thanks for trying that out maybe you should replicate what I am doing and have the camera facing the cube completely flat and adding a cube behind the camera so you’ll see the issue isn’t solved. I’ve tried what you did and I tried before a few other things that’s why I posted the problem because I run out of ideas.

I know this is a very specific use case but it is an important one in my job. I normally don’t have to reflect the environment like a mirror in any of my shapes but I need to do it this time and I am struggling with it.

Looks fine.

Though given that you’re working with an orthographic projection, which, like Joseph said above, doesn’t work well with reflections, maybe your best bet would be to fake a reflection effect through texture coordinates. Like so…

1 Like

Maybe that would be the best solution if there is nothing else that can be done to have perfect shading in orthographic view.

You could probably do something pretty clever by setting a fresnel node to the camera view on the texture coordinates, then mixing it with the reflection texture.

Actually this cannot be my solution as I have some elements in front of this body that are transparent and they get affected by this fake reflection behind and it breaks the realism. As if the object is blocking the environment the reflection under this transparent element would look completely different. It is hard to explain but yeah I can’t use this solution.

The only viable solution is to simply have a plane that contains an HDRI behind the camera so it get’s reflected similar to what the environment would be but the shading artifacts still remain. Maybe I can fix those small issues in post as what I need is only a still image.

1 Like

Maybe you should provide an example blend ??

Simple hexagon boolean from cube and some bevel modifier:


This is ortho view:

But this is a focal lenght of 500mm :

And this perspective:

And the outer face are ngons…


HexCutCube-noforestHDRI.blend (112.4 KB) (forest.exr from blender not included…)

Maybe just scale in normal direction to 0.0 ???

??? The cube had n-gons ??

There seems to be some weird geometry… maybe even overlapping??