NLA Action Strip set to repeat ... doesn't repeat

Simple enough (Blender 4.1.1): I link a character group into a scene, which has “walk cycle” actions. I push these down to form NLA strips, then switch to NLA editor. Select the strip and set “Repeat” to 4.0. I see the expected vertical marks appear and the strip gets longer. So far, so good, yes?

Then I hit “Play” and the cycle occurs … once. As the playback head moves forward through the “repeat” zones, it doesn’t!

Howcum?

I assume you did an override on your character collection and on the walk cycle action?

Is this the only object where this happens or does it not work if you test with a cube moving on X either?

Can you post screenshot of the NLA?

The library file already contains the walk-cycle action. In the new file, I selected it in Action Editor, pushed it down to an NLA strip, and in the NLA Editor specified that the strip should repeat. Visually, everything looked just right now in the editor. But, the action didn’t repeat.

I’m still a little fuzzy about overrides . . . but maybe(?) that’s a key. How would I use them in this case?

Did you override the action as well?
Because at least when I override a collection the action is still the linked action and after pushing the action down the “repeat” field in the NLA is grayed out and no number can be entered.

After overriding the action itself the “repeat” is not grayed out anymore and repeating works as expected.

So have you tried this with a cube moving along the x-axis? I would try this out just so that you can rule out that there is something wrong with the specific collection and/or walk action.

Or did you accidentially reassign the walk cycle action in the action editor after pushing it down? That would mean that the “normal” walk cycle action action is now above the one that you pushed down. Because blending of NLA tracks is set to “Replace” by default the NLA tracks bellow your “normal” walk action would not contribute to the final result.

I simply linked to the character collection, which contains the desired action among other things. I was then able to select this (linked …) action in the Action Editor and push it down to a strip. Unlike your apparent experience, the “Repeat” value on that strip was not grayed-out in the “Action Clip” section.

When I select the action in the Action Editor, I find that “Library Override … Make” is grayed-out! (As is “Reset” and “Clear!”)

To clarify my process: I first link to the actor group, then “Instance to Scene” and thereafter I am working with that. The correct action is identified, and it is played once.

• Create new file. Delete cube.
• “File…Link” to the actor file, select the group which contains all of it.
• Instance this group to the scene.
• In “Dope Sheet … Action Editor,” select the action. Find that all “Instance” options are grayed out for the action.
• Push to NLA strip. Switch to NLA editor. The strip is there.
• Set “Action Clip … Repeat” to, say, two. The visual confirmation is correct.
• Play. The action occurs once.

In the Actor file, the hierarchy in the Outliner is: Group, Armature, Animation, NLA Tracks. The actions are found there. (However, when I link to the file as described above, they don’t immediately appear in the NLA Editor.)

Blender 4.1.1.

:bulb: … The problem must be that I am simply “doing it wrong in the linked Actor file.” I need to be told how to fix it. :slight_smile: I used to know how it worked, but a lot has changed.

For instance: within the actor file, there are more “Actions” in the “Action Editor” (about 15) than appear in the list (2) when I link to the file. When I call up the “Action Editor” in the linked file, I see only the two that are in its “NLA Editor” section of the Actor.

So … I think that I’ve identified the root cause. But …

Update: I removed the NLA-strips from the Actor file and I am now trying to refresh my understanding of linking directly to Actions and having them be correctly associated with the armature in the linked Collection. Stay tuned. I’ll figure this thing out yet …

I guess if someone wanted to step in, right about now, with a “default-cube how-to-do-it step by step in 4.1.1,” that would be much appreciated. :slight_smile: My head is getting a bit sore, and I’m more than ready for my “d-Oh!” moment.

Hmmm…
Ok, I would try a clean start. I believe that maybe having NLA tracks in your character in the source file causes problems and perhaps not overriding the character object itself but only its collection.
Anyway, here a step by step guide on how it should work:

source = file where you have your orginal character and actions
target = file in which you have your linked character

  1. in source remove all actions from your character and zero him out (probably not necessary but cleaner)

  2. in source remove all NLA tracks and similar stuff from your character (maybe not necessary but cleaner)

  3. in source give all your actions fake users (just so you don’t lose anything)

  4. in target link your character from source

  5. in target link all your actions from source

  6. in target select character

  7. in target Object menu → Library Override → Make

  8. Select your character object (not collection)

  9. Your character is not yet overriden. You can not, for example change or keyframe its position

  10. Object menu → Library override → Make

  11. Your character is now overriden and you can change and keyframe its position

  12. In action editor chose one of the actions you linked earlier from drop down

  13. Push down

  14. Repeating in NLA should now work

Addendum:

If you have multiple things in your character colllection, like two seperate variations of hats for example you can now do the following:

  1. Select your overriden character without the hats
  2. Shift - M to link the character to a new collecion and call it “OnlyCharacter”
  3. The character is now in its original collection and in a second one
  4. Do the same with the Hats an put them in “Hat1” and “Hat2”
  5. Now you can make separate collection instances of your overriden character and the hats in order to easily hide hats or somehow further animate them individually.

That’s probably “it.” I will try this “cookbook” and report back. Thanks muchly.

When I link to the collection from the external file, I notice that I see only the collection in the Outliner. I do not see its components. The collection contains the individual components and the armature, but in the Outliner (in the “linking” file), the heirarchy ends with the Collection. I will continue to explore.

Yes, that is correct. First you override this linked collection.
Now you have access to the individual objects inside the collection.
You can now override these individual objects as needed in order to gain access to properties like location, rotation and actions and modifiers/constraints. Basically all the properties that on object level. After that you could override the mesh data and change that.
Note that some things are not implemented yet. For example you can override the mesh data and add an attribute but after quiting Blender and reloading the file the attribute will be gone. Same for materials unfortunately.

If you expand overriden collections in the outliner you can see which individual objects are overriden. The link symbol of overriden objects is a bit less gray. This is a bit difficult to see and they should probably chose a different color or something but if you know that it is there you can see it.

Indeed, I found that I had to first override the Collection, then override the Armature.

Of course this is confusing, because the Library Override selection that I made against the “Collection” was: “Make … Selected & Content.” Therefore I would have intuitively expected this to include “the Armature and everything else.”

Edit: Maybe what the programmers intended was … “only immediate next-level content.” This is easily a plausible interpretation: you really don’t want to override "everything below here." But this is not crystal-clear to the unfamiliar.

Likewise: a new glyph in the outliner is probably called-for to positively indicate “overridden.” (Unless I missed it …) A mere change of color doesn’t cut it. If I had seen such a “flag tag” on each item, I would have understood immediately what was going on, and exactly what was and was not affected.