NLA editor issues, is it a bug?

Hi, has anyone experienced problems editing the NLA strips in the dope sheet?

I have an animation in the NLA editor with several strips. So I press TAB on a strip to edit the keyframes, then I go to the dope sheet, and after editing the keyframes and going back to the NLA editor, I find that some other strips are not working. In the NLA editor only, because if I try to edit them in the dope sheet I can. Everything seems to be right in the NLA editor…

Is this a bug or am I doing something wrong?

yes I ran into that this morning. I think it is a bug because you can’t even replace the strip in the NLA anymore. Grrrrr!

Reloaded Blender and all is well. I’m making sure I’m tweeking in action editor.

Thanks, at least I know I’m not alone. I’ve had to change to the 2.78a version and make the changes for the animation and then reimport in the 2.79. So yeah it seems a bug in 2.79.
It may be a bug related to the evaluation curve. Have you used the curve for the transition in your scene stilltrying?

Editing the keyframes in the action editor worked sometimes for me, but not in all the cases.

I’m joining you. It is too inconsistent to keep working guessing if the NLA is going to work or not. I’ll be using 2,78 also! UGH!

Blender 2.78a has some issues as well.
I have been searching quite a lot, but there is no information out there about this problems with the NLA, I don’t know why.

I have found a workaround, deleting the strip that doesn’t respond, and then undo it with CTRL-Z.
Then the strip works as usual, and the evolution curve works well.

It seems that the NLA editor needs to be refreshed after the changes. I don’t know, maybe I’m missing something, is there other official way to do it?

Still with this workaround is not working sometimes in 2.79. For some reason, the evolution curve doesn’t work…
Now, what is keyframed in the graph editor, is not the values that are shown in the properties of the NLA strip.
Maybe now it’s because I have saved with the 2.78a, and there is a conflict between both versions.

Come on guys, 155 views and no answers about this, I would like to hear about your experience with the NLA editor. Or is it that people don’t use NLA too much? How do you do the animations, all in the dope sheet? I’m surprised that there isn’t any information about this bug.
Because actually this problem makes the NLA completely unusable.
I had to change again to the 2.78a to make some changes to the animation.

I have no use for NLA, can’t help you

Ccould you report it?

Really? And all your animations are done linearly with the dope sheet? BTW good portfolio!

It’s unclear what exactly you’re running into here. It’s unclear what “it stopped working” means. If you file a bug report like this, I’m just going to have to mark it “Incomplete”, ask for more info, and/or close it if you don’t respond :frowning:

Now, I’m going to take a guess and talk about 2 recent sets of bugs that I’ve encountered a few times this year. Hopefully one of these will solve your problems.

  1. At some point over the past year, I ended up fixing a nasty bug here where a particular timeline option (IIRC, it was the “only include keyframes from selected channels” option) was conflicting with some settings used internally by the NLA. What that meant was that if you were in tweakmode and went to toggle this setting, you could get Blender into a bit of an inconsistent state (where it thought no NLA strips were being edited), and then some rather weird things can start happening. The workaround for this particular issue is simple though: after toggling editmode a few times, just don’t touch any settings/options in the timeline.

  2. I’ve also run into quite a few files this year where people have accidentally enabled “Solo” mode, and then wondered why the NLA stack stopped getting evaluated. To check if that’s what’s happening here, just check if any of the “Star” icons beside each the NLA tracks is lit up (only one of them can be at a time). If one is, just uncheck it, and everything should go back to normal.

  3. On that note, you may also want to check that you haven’t muted the entire NLA stack either (i.e. speaker icon on the object-channel, on RHS of the channel list)

I also have never used the NLA Editor, I looked at it briefly before posting this and decided there was nothing in there that I couldn’t do in the Graph Editor (maybe a simplistic remark…). However, I should say that nowadays I do most of my animations with Animation Nodes, so I only really use the Node Editor. I have done a huge amount of “Mechanical” animations, including complex drive trains (engine, 12 speed gearbox, epicyclic gearbox, differential, etc. etc.) and have to confess I never once thought of using the NLA, or the Dope Sheet for that matter, they are all a mystery to me!

But this does not help you if you have a problem with it, just an explanation as to why I didn’t answer you, it was nothing other than that.

Cheers, and Happy New Year! Clock.

Well as I pointed out before, it seems a problem related to the curve influence of the strip. That’s why I wanted to know if others have the same issue. BTW I’m running Blender 2.79 windows 64 bits, in windows 7. For some reason once you get back from the tweaking mode, curve influence is not working. This problem doesn’t happen in 2.78a.
About the 3 possible causes you point out, no definitely is not that, as I said I checked everything is correct, and proof of that is that it works on 2.78a.

I have never used NLA for animation, and I never needed it, but now I’m doing character animation, and I can see that, because of the complexity of this kind of animation, it’s quite an important feature.

Nice of you Aligorith to clarify the situation with such openness. Personally, I won’t see much use for the NLA (being more of a creature/character animator) until it acts more as a kind of animation layering system (additive keying in the viewport etc, we talked about this some time ago). Now I didn’t work on any big project with Blender so far (I work on Maya), but I’m if I were to, I’d have at least some use for the NLA - mixing “idle” animations of background characters, that kind of thing.

@macalister, I don’t really use the dopesheet - in blocking stage, sure, but then it’s graph editor all the way. Thanks for your kind words.


Thanks very much Algorith for replying. I was able to replicate this by the following.

Establish more than one action.
Select a top action and enter tweak mode. Unpin the NLA strip in tweak mode.
Use the dope sheet to move the keyframes to another position/section.
Exit tweak mode.

That caused the issue. I think it is the same one.
Is this faulty use of the tweak?

Timtestnla.blend (466 KB)

PSS: I pushed both actions down on the action editor. Went to NLA. Added a track. Moved last action up one track. Then went to tweak mode if it makes a difference.

PS Are you Dr. now?

Stilltrying, this is not because of a bug, this is because you have move the keys outside the limits of the strip. You can see it in the green area when you are in tweak mode, the keys are moved outside. Just change the end frame of the Action Extents option and you will see that the keyframes are active.
Please check if this was the same problem you had before in your scene, so that we can know if there is a bug or not.

This is driving me nuts. I cannot replicate it, and now I don’t see the bug, sometimes happen I don’t know why.
Now that I see what you are doing stilltrying, I’m starting to think that perhaps I mistakenly moved some keyframes of the influence curve, instead of the ones of the bones.
Curiously the curve influence of other layers appears in the dopesheet together with the keyframes of the bones of the layer selected.

Oh crap. Thanks.
Never mind algorith.

stilltrying which was the problem in your scene, did you have the curve influence enabled?

Yes, but now I can’t replicate it. Go figure!

This is the problem. I couldn’t replicate it atm, and I cannot share the scene, but I deleted everything except the bones with the problem, and with the hierarchy, and I’m attaching it. They are some bendy bones, with some slight noise modifier, but the problem happens with keyframe animation as well, it is not the modifier.

For some reason the curve of the animated influence has stopped working, the value of the keyframes at the graph editor doesn’t match the value at the properties panel of the strip, which remains fixed all the time. Once it happens there is no way to make it work, I tried deleting the curve and keyframe it again but nothing. It seems that has lost the connection with the data from the graph editor, I don’t know I have no idea. The thing is that everything seems right, but at some point after some tweaking, you discover that the animated influence has stopped working. Fortunately I didn’t save my scene when this happened, so I could try again.

I wasn’t able to replicate it in a simple and controlled way. I will try again, but this is quite time consuming, and at the moment I cannot focus on it.
I have no idea how to report this, should it be enough with this?


Curveinfluencebug.blend (2.65 MB)