NLA strip and action don't match

I’m having troubles with NLA and Actions not matching.

Here you can see how frame 14 on the armature should look:

But when I convert this action to NLA strip or simply add the animation to NLA after removing the link in Action window, it looks like this:

You can see there is quite big difference in one bone (Base bone). This happens only in one frame, and there is no keyframs for that bone in that frame.

I have had this problem before, and could not find any way to fix it then, but now when it happened again I’m sure it isn’t just “random” thing, but something I did wrong.

You can download the blend file here:

If you find away to fix it, please tell me.

Oh, if you are wondering: the model is for duke3D OpenGL port.

Looks like a bug to me.
Could you post this in the bugtracker over at ?
It would be much appreciated.


I posted it.
Thanks for the reply!

What do the underlying IPOs look like? I know that everything ultimately gets converted to IPOs and maybe something isn’t being cleaned up.

Whew! Glad it looks like a bug, I worked on this for an hour.

I don’t know what you mean by “underlying IPOs” but I do know that this should not happen.
Thanks to Enzoblue and others spent their time trying to fix this. I actually was hoping it was not a bug, since now somebody has to fix it -and I can’t :expressionless:

What I mean is, after you think you’ve cleaned up all the things that could interfere with the NLA-strip, click over to the IPO window and check all the various types of IPOs.

Sorry that it took so long to reply!

Yes I checked that, but apparently it just is a bug in Blender. I reported it in the bugtracker, and it seems that Ton fixed it. I am yet to test it tought, but I believe in him :wink: