No Add-ons available: "Missing script files" error, Blender 3.5

Hello, everyone. Hope all is well.

Running gnome on fedora 37.
I started blender today for the first time in about a month. My start up file was reset to factory and all my add-ons that I use for 3D print modeling were removed. Went to put them in again and have this screen:

I tried loading factory defaults.
I don’t really know what to look for in /usr/share/blender/3.5/scripts. But there was a directory called site on the blender repository that I downloaded and added.
I tried dnf remove/add.
I looked at missing script files message on installing add-ons, missing script files, and some others (can’t add due to 2 link limit on new users).

Should I find these files on the blender repository and insert them manually?

Thank you,

Hmm… of course by (docs.blender manual configuration) loading-factory-settings the default values should be set and (maybe ?) also all extra addons disabled… but removed… !?

Well…if you are already had reset them…then just try to re-install blender… this should be the easiest way…

This said… you can have a look into…

and maybe also ( these are usually in the alphas but seems to be not in every release ??)

Just to be clear, when you say “Went to put them in again”, did you try to reinstall them with the install button, or just turn them back on?

I would have thought add-ons you install yourself would be in ~/.config/blender/X.x/scripts/addons

Navigate over to the 3.5 directory, check what’s in there. Also check if they are in 3.4 (assuming you had them installed in 3.4). If they are missing in 3.5 but there in 3.4, just copying them over then restarting blender should work. But if not you could try uninstalling the missing ones and reinstalling them.

There’s probably a smarter way them to handle it, but I don’t necessarily do smart.

Thank you for asking that. I meant turn add-ons back on, not install.

I ran a diff on my directory and the one on the git repository. The only difference was that ‘site’ directory that I mentioned.

I did a reinstall, and that did not help. I was actually surprised that after doing a fresh install with dnf, Blender still used my saved startup file. I’m not super savvy on package management. But it’s apparently not really doing a fresh install. I used dnf remove blender and dnf install blender. I think this removed the previous version directories (i.e. 3.4) because I don’t see them there anymore. :confused:

I did figure out a less-than-satisfying work-around by installing the flatpak. Add-ons seem to be working this way. This will be good enough for now.

Thank you.