No Alpha Channel?

Hey everyone! I’m sure this has a really simple fix that I’m just not seeing but I can’t render anything out of blender with an alpha channel. I set the surface in the world tab so that the color is completely transparent and I am rendering as png files with the RGBA tab selected but when I render it out there is still a dark gray background that I am having trouble keying out. Does anybody know how to fix this?

If using cycles renderer enable ‘Transparent’ in the Render / Film settings
If using Blender Render set Alpha to Transparent in the Render / Shading settings or disable ‘Sky’ tickbox in the Render Layers settings.

thank you so much!!! :d:d:d