No alpha in Blender Internal render (r53999)

I am experiencing a problem (bug?) and want to see if anyone else is getting the same behavior. In a build I grabbed this morning (r53999) I am not able to get alpha in a blender internal render.

Alpha works fine in cycles, but no alpha is working when using the internal render. (RGBA is checked) Also works fine in an older build.

Did you build that yourself? The latest I can find is r53979.

Grabbed it from blender BuildBot. That always has the latest build here.

There is another (newer) version up already, so I just downloaded that and it also appears to have the same problem.

I believe it is a bug in these new versions, but was hoping someone else could confirm before I report it.

Yeah, that’s what I thought. The build number, at the time, ended in 979, not the 999 you had posted, so I wanted to be sure we were on the same page.

Anyway, I tried it with 54014 and 53907 and they’re both missing alpha channels for TIFF images. So, it’s confirmed.

Please report bugs into our tracker:

Now that I know it is an actual bug, I have submitted it. I wanted to make sure it wasn’t just me first.

Update: not a bug.

Basically, the default sky now is opaque alpha, so you need to set alpha transparent explicitly through a drop-down that is located in the render/shading tab.

Here is the response in case anyone else has the same problem.

Previously you could save this way with an alpha channel, but the result would in fact give some incorrect color fringing on edges if you didn’t also set the shading alpha option, which is now required to be set.

Ah! Thank you very much! I was having a devil of a time figuring it out.