No alpha in Executables??

Does anyone know why alpha textures (PNGs to be precise) dont seem to work when you make an EXE? If so how do I fix this; is there a script or something i can use?


Pack the textures first.

See ya.

I tried packing the textures but I have the same problem. The textures are there but the alpha channel is being ignored.

Thanks for the quick answer anyway,

Press F to enter the face mode, and click on the alpha button.

See ya.

Sorry, I should have explained myself better…
I know how to use Alpha textures and they work fine in my blender environment. The problem arises when I make an Executable from my blend file. Only now are the alpha textures ignored…

Thanks anyway…

What is the blender version that are you using?

See ya.

Blender 2.36

Could you post the png file or the blend?

See ya;

Not easily i’m afraid
Though its quite easy to recreate. Just make a blend file containing an alpha textured plane and make it an executable.

Lol, I do not need to do that, because its working for me.

Put the png file here, so then I can test it.

See ya.

Umm… Stupid question but how do I upload an image to the boards?

type ![http://yoursite/image.png](http://yoursite/image.png)

or send it to me [email protected]

I’ve sent the PNG file to the E-Mail address you specified.
Thanks for taking the time to help me!

There was not any alpha channel in that png file.

I recreated it using Gimp, and now that file has a real Alpha Channel.

Pay more Attencion next time.

See ya.

Then how come it worked in blender?
Oh well, Never Mind. I was not using The Gimp to make these files which may be why the Alpha channel did not work properly.
Thanks anyway.

as i always say is that you shouldn’t ever do pack texturing! many people have problems with opening packed textures especially textures such as .png as they often crash blender on certain systems namely Windows - the best way to include textures is to pack the data then unpack the data selecting “ask for each file” and then click on the //textures/image.type option. This will create a folder called textures that needs to be included with the .blend. This not only compressed the files even more when put into a zip but it also makes it possible to avoid the error by eliminating the png textures and then opening the .blend - also although a png texture might be more compact it is preferred by most standards that you use tga files. Hope that helps!

oh by the way - it probably didn’t work in the .exe but in blender beause often the black color of a png with alpha mapped will often make that the alpha color - atleast that has been my experience when messing with textures that “have” a alpha channel (ie: if you make a RGBA jpg texture from blender - the gimp doesn’t recognize it but blender does!)