no bump effect

hey all for my current project I need to make some puddles on a street, and that for I wanted to use a bump effect. I combined 2 textures and made them black and white. I pluged the final mixshader-node into the output’s displacement, but there’s no effect. Here’s a screenshot of the final texture:


You have to plug in the texture into the displacement not the bsdf.

Also, Bump/Displacement mapping ONLY works on exsiting geometry. Depending on what your topology looks like there might not actually be anything there to displace.

You have to plug in the texture into the displacement not the bsdf.

I know I just pluged it into the bsdf for the screenshot :wink:

Also, Bump/Displacement mapping ONLY works on exsiting geometry. Depending on what your topology looks like there might not actually be anything there to displace.

I don’t know exactly what you mean with that :slight_smile:

Why have you not attached an example blend file that includes all textures to help those users who may wish to help you

here it is, but it’s a pretty confusing node-setup

problem.blend (633 KB)

He means that you need to have enough vertices to actually bump something around with the texture - currently you have a low poly object, maybe try with a subdivided version.

After looking at the file, I can’t tell what you are trying to achieve - the nodes are all kinds of crazy for something so simple in construction. I added a light emitting plane and could see it through you robject, so I suppose you are working with some nodes that are transparent? Apply the effect you are looking to create at a simple level with a default cube, and then add it in to your file after succeeding with your intention.

Well it seems confusing, but it combines two black and white textures, with a little contrast-correction to one that should be used as displacement

I already added a subsurf modifier (without applying it), shouldn’t this work as well?

Are you trying to work with transparency? And have you added a light source yet?

Are you wanting to use the texture as a bump map? If so then you don’t need high res real displacement.
Just looking at your node setup you are feeding output from shaders into the displacement. Just feed the adjusted texture into the displacement, remove the shader nodes

Attachments


I’m trying to use two combined textures :slight_smile:

Even if I just use a |image texture| – |RGB to BW| – displacement, it’s not working :confused:

thanks, I already saw this, but I’m using cycles. I think I just have to make a texture and put it into blender instead of combining two textures in blender

Nah. Bumpmapping works without any geometry, it’s just sometimes wrongly called displacement mapping.
A bumpmap, what ghost tries to use, works on a quad as well, just like a normal map.

Cycles’ working great, it’s your fault :smiley:
You have to learn the difference between image and shader.

You can’t use a shader for displacement, and you can’t mix 2 images with a shader mix node.
Also, your blend isn’t helping, no textures in it :wink:
try this:

make a plane, uv unwrap.
1 diffuse and 1 specular in a shader-mix-node and into material surface
2 textures with vector to uv and those in a color-mix-node and into material displacement.
And set the textures for the bumpmapping to non-color-data

You got the idea alright, but seem to have a complete lack of the basics.

I guess that’s what you’re after:

Cycles’ working great, it’s your fault :smiley:

I know, cycles is awesome :wink:

thanks, your picture helps a lot !!!