No Bump

I have a plane with a bump map. The bump shows in a render but not in the GE. Using GLSL materials, and I think my graphics card is a good one (GeForce GTX 280). Blend attached. If you can see the bump when you hit P please let me know so I know it’s my hardware and not something I have/haven’t done.


bumpless.blend (164 KB)

Click the normal map button in the map image panel in texture buttons.

I don’t see it on my machine, but then I have an ATI card and GLSL in Blender is notoriously flakey on ATI cards. If it’s not working on your Nvidia card though I suspect that there’s something more wrong. I took a quick look, but I haven’t used GLSL yet so I couldn’t see anything obvious.

Anyone else see anything off here?

I clicked on Normal Map - made no difference in the GE and the render was no longer good.

Perhaps I’ll have to rethink using the GE for interactive walkthroughs. I’d like a bit more realism than one can get with colour maps alone.

Allright I downloaded your .blend. Steps to fixing it.

  • Switch to “Textured” mode
  • In the “Texture Buttons Panel” You must click on Normal Map.
  • In the Game Menu (At the Top) enable “Blender GLSL Materials”

Here is a demo I did myself while testing the features, see if they show up for you. You should be able to see a bump map for the sphere and the floor, and the sphere should be casting a shadow.


GLSL-Test.blend (407 KB)

Thanks for that, much appreciated. I had tried all of those but obviously not in the right combination. Also, setting my Nor slider too high in the Map To panel was not a good idea.