No CPU + GPU option on the same rendering with 2.79.3 (Xubuntu)


(serviteur) #1

Hello.

I was download Blender (2.79.3) https://builder.blender.org/download

I have laptop with Quadro 4000M and eGPU GTX 580 . I was install the last driver Nvidia 3.90.25 for the PPa: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa



but I have no option to use the CPU + GPU on the same render !

How to fix ?

OS: Voyager 16.04.4 (Xubuntu)


(English is not my native language) #2

Hi.
You open the terminal and you share the result of each of the following commands:

cat /proc/driver/nvidia/version
nvcc --version

Install this package:

sudo apt-get install mesa-utils

Now share output of:

glxinfo | grep -i opengl

PS: You reboot the system after installing new driver, right?


(özgür) #3

Nvidia control panel > program settings > add:blender.exe
you can try it


(serviteur) #4

@YAFU

serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  390.25  Wed Jan 24 20:02:43 PST 2018
GCC version:  gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.9) 
serviteur @ HP-EliteBook-8760w  ~

serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ nvcc --version
Le programme « nvcc » n'est pas encore installé. Vous pouvez l'installer en tapant :
sudo apt install nvidia-cuda-toolkit
serviteur @ HP-EliteBook-8760w  ~



The program “nvcc” is not yet installed.

└─ $ ▶ sudo apt-get install mesa-utils
[sudo] Mot de passe de serviteur : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
mesa-utils est déjà la version la plus récente (8.3.0-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
serviteur @ HP-EliteBook-8760w  ~

mesa-utils is already the most recent version.

serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ glxinfo | grep -i opengl
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro 4000M/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 390.25
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.25
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.25
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ 


(MadeWithFeet) #5

hum, isn’t rendering with GPU + CPU at the same time only in 2.8 ?

Cycle should show your GPU though…


(English is not my native language) #6

Mmm, nvidia driver seems properly installed and loaded.
Do you have installed “libcuda1-390” package, right?
A very important question that I should have asked. Can you see GPU compute devices in official release of Blender 2.79 or 2.78 versions? Is everything working well in those versions?


(serviteur) #7

no isn’t rendering with GPU + CPU at the same time only in 2.8


(serviteur) #8
serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ sudo apt install libcuda1-390
[sudo] Mot de passe de serviteur : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libcuda1-390 est déjà la version la plus récente (390.25-0ubuntu0~gpu16.04.1).
libcuda1-390 passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶

libcuda1-390 is already the most recent version

yes, I see GPU compute devices in official release of Blender 2.79 or 2.78 versions


(Nirved) #9

Quadro 4000M is a Fermi card, GF104 (with cuda compute capability 2.1). Blender 2.79a should work, not sure about 2.79b when it comes. Master will not work anymore.
https://lists.blender.org/pipermail/bf-cycles/2018-January/003207.html


(English is not my native language) #10

Edit:
Sorry, I had not read carefully what Nirved had written…

So if drop support for Fermi in master rules now, that explains the problem.


(English is not my native language) #11

Hello serviteur.
I’m not sure how to compile CUDA Kernel when Blender code (2.79 from master/buildbot) intentionally disable support for those old graphics cards.
But we could try first by installing CUDA Toolkit. What version of Xubuntu did you have? You do:

sudo apt-get install nvidia-cuda-toolkit

You will be patient until the installation is completed (approximately 600MB must be downloaded). Then when the installation successfully finishes, you restart the system.

Then you try Blender 2.79 from buildbot and you see if it can compile the kernel when you make the first render with GPU.


(serviteur) #12

Thank Yafu,

I have Xubuntu 16.04.4 (Voyager Linux)


(English is not my native language) #13

Have you installed nvidia-cuda-toolkit packages?
16.04 repositories provide a supported version of CUDA Toolkit for your cards. But I do not know if installing CUDA Toolkit is enough, or if you also have to change something in the Blender code from master.
Another thing, there have been other times where developers provided CUDA kernels compiled with different versions of CUDA toolkit for different cards. I’m not sure why they are not doing this this time. I’m not sure if it will work for Blender from master.


(toxsickcity) #14

Hi all

So I got word 5xx cards and the new compiler are a no go…

Looks like for 5xx cards have to use normal blender. Any build with (new compiler) are not supported.

I asked devs. Here
https://developer.blender.org/T54534


(serviteur) #15

I installed nvidia-cuda-toolkit

serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ sudo apt-get install nvidia-cuda-toolkit
[sudo] Mot de passe de serviteur : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants vont être installés :
  libcublas7.5 libcudart7.5 libcufft7.5 libcufftw7.5 libcuinj64-7.5
  libcurand7.5 libcusolver7.5 libcusparse7.5 libnppc7.5 libnppi7.5 libnpps7.5
  libnvblas7.5 libnvrtc7.5 libnvtoolsext1 libnvvm3 libthrust-dev libvdpau-dev
  nvidia-cuda-dev nvidia-cuda-doc nvidia-cuda-gdb nvidia-opencl-dev
  nvidia-profiler nvidia-visual-profiler opencl-headers
Paquets suggérés :
  libvdpau-doc libcupti-dev nvidia-driver
Paquets recommandés :
  libnvcuvid1
Les NOUVEAUX paquets suivants seront installés :
  libcublas7.5 libcudart7.5 libcufft7.5 libcufftw7.5 libcuinj64-7.5
  libcurand7.5 libcusolver7.5 libcusparse7.5 libnppc7.5 libnppi7.5 libnpps7.5
  libnvblas7.5 libnvrtc7.5 libnvtoolsext1 libnvvm3 libthrust-dev libvdpau-dev
  nvidia-cuda-dev nvidia-cuda-doc nvidia-cuda-gdb nvidia-cuda-toolkit
  nvidia-opencl-dev nvidia-profiler nvidia-visual-profiler opencl-headers
0 mis à jour, 25 nouvellement installés, 0 à enlever et 73 non mis à jour.
Il est nécessaire de prendre 618 Mo dans les archives.
Après cette opération, 1 211 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://cm.archive.ubuntu.com/ubuntu xenial/main amd64 libvdpau-dev amd64 1.1.1-3ubuntu1 [35,8 kB]
Réception de:2 http://cm.archive.ubuntu.com/ubuntu xenial/multiverse amd64 libcublas7.5 amd64 7.5.18-0ubuntu1 [14,1 MB]
Réception de:3 http://cm.archive.ubuntu.com/ubuntu xenial/multiverse amd64 libcudart7.5 amd64 7.5.18-0ubuntu1 
Réception de:17 http://cm.archive.ubuntu.com/ubuntu xenial/multiverse amd64 libthrust-dev all 1.8.1-1 [430 kB]
Réception de:18 http://cm.archive.ubuntu.com/ubuntu xenial/multiverse amd64 nvidia-cuda-dev amd64 7.5.18-0ubuntu1 [201 MB]
Réception de:18 http://cm.archive.ubuntu.com/ubuntu xenial/multiverse amd64 nvidia-cuda-dev amd64 7.5.18-0ubuntu1 [201 MB]
Réception de:19 http://cm.archive.ubuntu.com/ubuntu xenial/multiverse amd64 nvidia-cuda-doc all 7.5.18-0ubuntu1 [73,5 MB]                                                                                                                                                        
Réception de:20 http://cm.archive.ubuntu.com/ubuntu xenial/multiverse amd64 nvidia-cuda-gdb amd64 7.5.18-0ubuntu1 [2 610 kB]                                                                                                                                                     
Réception de:21 http://cm.archive.ubuntu.com/ubuntu xenial/multiverse amd64 nvidia-profiler amd64 7.5.18-0ubuntu1 [2 240 kB]      


                                                                                                                                               
                                                                                                                                                                                                                           


Sélection du paquet libcusparse7.5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libcusparse7.5_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de libcusparse7.5:amd64 (7.5.18-0ubuntu1) ...
Sélection du paquet libnppc7.5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libnppc7.5_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de libnppc7.5:amd64 (7.5.18-0ubuntu1) ...
Sélection du paquet libnppi7.5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libnppi7.5_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de libnppi7.5:amd64 (7.5.18-0ubuntu1) ...
Sélection du paquet libnpps7.5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libnpps7.5_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de libnpps7.5:amd64 (7.5.18-0ubuntu1) ...
Sélection du paquet libnvblas7.5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libnvblas7.5_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de libnvblas7.5:amd64 (7.5.18-0ubuntu1) ...
Sélection du paquet libnvrtc7.5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libnvrtc7.5_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de libnvrtc7.5:amd64 (7.5.18-0ubuntu1) ...
Sélection du paquet libnvtoolsext1:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libnvtoolsext1_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de libnvtoolsext1:amd64 (7.5.18-0ubuntu1) ...
Sélection du paquet libnvvm3:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libnvvm3_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de libnvvm3:amd64 (7.5.18-0ubuntu1) ...
Sélection du paquet libthrust-dev précédemment désélectionné.
Préparation du dépaquetage de .../libthrust-dev_1.8.1-1_all.deb ...
Dépaquetage de libthrust-dev (1.8.1-1) ...
Sélection du paquet nvidia-cuda-dev précédemment désélectionné.
Préparation du dépaquetage de .../nvidia-cuda-dev_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de nvidia-cuda-dev (7.5.18-0ubuntu1) ...
Sélection du paquet nvidia-cuda-doc précédemment désélectionné.
Préparation du dépaquetage de .../nvidia-cuda-doc_7.5.18-0ubuntu1_all.deb ...
Dépaquetage de nvidia-cuda-doc (7.5.18-0ubuntu1) ...
Sélection du paquet nvidia-cuda-gdb précédemment désélectionné.
Préparation du dépaquetage de .../nvidia-cuda-gdb_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de nvidia-cuda-gdb (7.5.18-0ubuntu1) ...
Sélection du paquet nvidia-profiler précédemment désélectionné.
Préparation du dépaquetage de .../nvidia-profiler_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de nvidia-profiler (7.5.18-0ubuntu1) ...
Sélection du paquet opencl-headers précédemment désélectionné.
Préparation du dépaquetage de .../opencl-headers_2.0~svn32091-2_all.deb ...
Dépaquetage de opencl-headers (2.0~svn32091-2) ...
Sélection du paquet nvidia-opencl-dev:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../nvidia-opencl-dev_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de nvidia-opencl-dev:amd64 (7.5.18-0ubuntu1) ...
Sélection du paquet nvidia-cuda-toolkit précédemment désélectionné.
Préparation du dépaquetage de .../nvidia-cuda-toolkit_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de nvidia-cuda-toolkit (7.5.18-0ubuntu1) ...
Sélection du paquet nvidia-visual-profiler précédemment désélectionné.
Préparation du dépaquetage de .../nvidia-visual-profiler_7.5.18-0ubuntu1_amd64.deb ...
Dépaquetage de nvidia-visual-profiler (7.5.18-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de libvdpau-dev:amd64 (1.1.1-3ubuntu1) ...
Paramétrage de libcublas7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libcudart7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libcufft7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libcufftw7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libcuinj64-7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libcurand7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libcusolver7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libcusparse7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libnppc7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libnppi7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libnpps7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libnvblas7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libnvrtc7.5:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libnvtoolsext1:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libnvvm3:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de libthrust-dev (1.8.1-1) ...
Paramétrage de nvidia-cuda-dev (7.5.18-0ubuntu1) ...
Paramétrage de nvidia-cuda-doc (7.5.18-0ubuntu1) ...
Paramétrage de nvidia-cuda-gdb (7.5.18-0ubuntu1) ...
Paramétrage de nvidia-profiler (7.5.18-0ubuntu1) ...
Paramétrage de opencl-headers (2.0~svn32091-2) ...
Paramétrage de nvidia-opencl-dev:amd64 (7.5.18-0ubuntu1) ...
Paramétrage de nvidia-cuda-toolkit (7.5.18-0ubuntu1) ...
Paramétrage de nvidia-visual-profiler (7.5.18-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...
serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶

No change. ( isn’t rendering with GPU + CPU on Blender 2.79 from buildbot)


(English is not my native language) #16

Sorry, your cards will definitely not be supported in Cycles from master or 2.8, no matter what you do.
Here the explanation: