No FK/IK Switch in Blender with a MakeHuman Model

When I import a MakeHuman rigged mesh, the bones all import fine and it works in FK mode, but there is no FK/IK switch like you can see in this video:

This is all I see:

Thanks for your help!

MakeHuman 1.0.2
Blender 2.77 (but I’ve tried lots of older versions and none work)
Windows 10

Attachments


I came here to research the same question today. I notice no one answered. Did you ever find a solution? I tried the newer MakeHuman, which was a lot of pain to install, including an undocumented install of plugins for blender I had to search for.

I think I just stumbled on part of the answer: when you’re choosing to import, uncheck the box marked “Override Export options” (wow, what an unhelpful name for that button, cuz, you know, you’re importing.) You’ll see a bunch of boxes to tick. After choosing some options that you thought you already chose in MakeHuman’s export options, you’ll eventually find the FK/IK switches in … a different place now. Look in the T panel, the left side, not the N panel on the right where you used to see these controls.

Dig into that because that’s all I know right now. I’m going to spend some time trying to find.

So here is what I do:


Select one foot.IK bone (for example) and make sure you see the right side menu (key N - its a toggle). Then set the ikfk-switch variable to 1 for IK and 0 for FK. These values/boxes DO NOT SHOW if anything other than an IK target bone is selected.

Hope this helps @wellerankanto also… I cannot find your thread on Animation & Rigging BTW.

Cheers, Clock.

EDIT:

You can keyframe this value to change from IK to FK during an animation (RMB-Click => “Insert Keyframe”)

EDIT 2:

This means of course that you can have the left leg in IK mode and the right leg and both arms in FK mode - it is NOT a global setting for all limbs in IK, or all limbs in FK, therefore it doesn’t show unless you select an IK target bone…

clockmendr, once again, very kind of you to help. Although our screens are quite different, I found the solution (I think).

I tried this with a newer version of MakeHuman, I believe, than the one you’re showing: I’m using v1.1.0. I’m trying it with Blender 2.78c on a Mac.

Those properties in your screen shot don’t appear here, nor does the panel labeled “Properties,” but I think I found it, here on the left side (screenshot)


When I unticked the box for 'LegIkToAnkle" the foot snapped to the IK target’s position and moves like I’d expect. In the same screenshot, you see I have a number greater than 1.00 for the left’s “LegIK” but I was experimenting. It doesn’t seem to matter as long as it’s 1.0 or greater.

I think actually you are using the MakeHuman armature, whereas I use the Rigify armature - it’s personal preference, but, Rigify is available as an Add-on to Blender so you can use it to rig characters you make yourself. I am used to Rigify so always use it when I export from MakeHuman.

I use 2.78a just now on my Mac, MakeHuman 1.0.2.

Using more than 1 won’t matter, what it is actually doing is the set the influence of the IK Modifier on the shin bone for the leg for example. Influences for mods are 0 for inactive and 1 for active, I suspect the code will ignore anything you use over 1 and just set the IK mod influence to 1.

Pleased it’s sorted for you.

Cheers, Clock.

I was under the impression that MH 1.0.2 wouldn’t work with 2.78, but if all I need to do is install the right plugins, I might just try that. I’m very glad you mentioned it.