'No image rendered' YES THERE WAS!

Hi guys,
I’ve been working on a project for a few weeks now, it was just about finished so I rendered it, and then pressed F3 to save the image, and it says:

No Image Rendered

Which is odd because I’ve been rendering and saving that same image for while without any problems.
So I tried a quick work around by clicking the animation button (changing end to 1) and it renders and then just as it finishes rendering and goes to save it as a PNG, Blender crashes.
Which leads me to believe that for some reason, Blender can’t output the result.

I tried it on a second computer and got the same result. I’ve searched the forums and found nothing.

Anyone know what the problem could be?

Also I just noticed, in the blender command window it says:

Calloc returns nill: len=4912520000 in Combined rgba, total 349675960

Corrupted .blend? Or perhaps another app had a lock on the file?

EDIT: Calloc() returns nill probably means that you’ve run out of memory.

Run out of memory?
Like RAM right?

Because I’ve restarted the PC and tried it on another (both PCs have 2gigs RAM) and get the same result :frowning:

What do you recommend I do?


K. I went there expecting to find a “no image rendered” troubleshooting section, but alas, it just tells you how to render and save an image.

Anyone else?

More info:
I’m trying to render the image at 6400 x 4800. It says, “image not rendered” when rendered at 75% and 100%. However it saves when rendered at 25% and 50%.

So I guess it just doesn’t like rendering that large??

Anyway to get around it?

when they told you about memory, they were talking about your hard drive. an image so big will need more space than you have available on the drive you’re saving to.

Ps: I’m not sure that’s the answer, but it looks like it.

But I have nearly 1TB of free space!!

So I don’t think it’s that. But thanks for the suggestion!

I’m open to anything at the moment. This is really driving me insane!

Try http://krypt77.altervista.org/htm_krypt/blender_region.htm . It is likely that you are running out of RAM. It is trying to allocate almost 5GB so it’s kind of understandable…

so I was wrong and it was RAM after all…

Yeah you weere wrong. Windows (not sure of linux) will let you know loooong before you reach less than 5gb available space on your hard drive that you may start having issues. Its the same catch all that stipulates that you must have at least 14-15% free hd space to do a system defrag.

Seems like an answer. It makes sense because it will render a 6400 x 4800 render of a cube fine.

However, I tried the script you posted but it crashes on me :frowning: and I don’t know why.
Not compatible with blender v2.45?

So is there any other way to break up the pic into several pieces so it uses less memory?

I also read somewhere that you can tell windows to use some hard drive space as memory when RAM runs out. Like deligate 200mb as a buffer, for RAM. Would this work?

Keep the advice coming guys, I appreciate it a lot!

Yeah but it’s okay, he’s just trying to help. :slight_smile:

What sort of error does it give when it crashes? There might be other scripts worth trying out.

One way would be to try the camera shift option. Basically you can set up render size to half (ie. 3200 x 2400). Shift camera (see camera panel) (x: 0.5 y: 0.5*2./3 (need to tweak y because it doesn’t take aspect ratio in count. Note that you can enter formulas directly into fields as they are evaluated by Python. 2. means that it’s float. Otherwise division is done using ints which doesn’t yield a nice result (this is going to be fixed in Python 3.0 though :slight_smile: ))). This will give you upper right corner of the image.

Note that you need to move the camera towards the target because of the shift. This can be done by selecting the camera, hitting g, and z twice (should move in local space of camera). You need to this only once.

After you have rendered upper right corner, you need the missing three. Following combinations for shift should work (x and y refer to values used for upper right corner): (-x, y), (x, -y) and (-x, -y).

After you have successfully rendered the corners, you need to combine them. There are probably many ways you can do this. I would advise against using Blender’s compositor this for though. It just cannot manage with images of that size (about 2k is reasonable for most setups). Look into ImageMagick (http://www.imagemagick.org/script/index.php) and co.

the page link I gave gives tips on things to do in order to reduce memory usage.

Look at it this way: you are trying cram 10 pounds of sugar into a 5 lb sack. You either need to put in less sugar, or get a bigger sack. “Sugar” in this case is the scene you want to render. Look at the paragraphs beginning with Decreasing Render Time, and try the things there to reduce you memory use. You might try Save Buffers, for example. BeBraw is giving you more info on tip #9 in Blender/OS Configuration Settings paragraph.

Oh. Sorry I over looked it.
I just read that section and it seems to have some good ideas. Especially the Save Buffers button. However when the button is pressed, and I go to render it says, “cannot save render buffers, check the temp default path”. I’ve looked for a filepath box but I can’t find one.

I tried the render to image editor also, and it renders but then when you go to save it, it clears and goes blank. :frowning:

This sounds very advanced! But I did my best to understand it, but I don’t think it will solve the issue. When blender crashes when I used the last script you gave me it says in the command box, the same error it does when I render it normally:

Calloc returns nill: len=4912520000 in Combined rgba, total 349675960

Which says to me, it’s not to do with the creating and rendering the image, it’s to do with the saving part.

It makes absolutely no logical sense to me either.

I’m still open for ideas and tips !\

Thanks Papa Smurf and BeBraw for trying to help me sort this out. You’re both very kind. :eyebrowlift:

To speed things up, I’ve uploaded the .blend here:

Pull down the top header and enter a location (folder) for the temp folder or on windoze just create a folder named “tmp” without the quotes on your C drive.

Press F1 to save the image.

You can reach critical mass with the ammount of verts and/or textures you have in your scene in which case the only solution is more RAM but this isn’t the problem in your case.

You can also use Really Big Render .py .

After download I can see that your output size of 6400 X 4800 is the problem. Even with the save buffers option on Blender will likely crash no matter how much RAM you have available when it tries to stitch the render tiles into a final composite.

Try using a still image editor like Photoshop to enlarge a much smaller version of the image after render (bicubic smoother filter or genuine fractals plugin) rather than rendering a monster like that.

Wow, I have the EXACT same problem :stuck_out_tongue: Same error, same way of trying the anim button, and it’s rendering on another PC with 2 gb’s of RAM right now :stuck_out_tongue: But my picture is even bigger :frowning: (7016 x 4961). So that means I’m doomed :frowning:

And most of the workarounds don’t even apply to me because I have PANO on to create an effect :frowning:

Btw, have you tried Shift + B in the camera window, and then specify an area which it needs to render first? And if you press Crop in the anim tab, it only renders that area. This doesn’t apply to me either because it’s incompatible with panoramic rendering :frowning:

I’m as eager for a solution as you are :stuck_out_tongue: Gonna try some of these things after my second pc finishes.

um, Rambo mentions a good point…so are you guys trying to print like a wall-size poster? because 6400/72dpi is like 89 inches wide…over 7 feet. Or for a vehicle wrap that is like…53 feet long? (vehicle wraps are printed at 10 dpi)

and i dont think any normal app will handle an image size of…9.2gigabytes (6400x2400x24-bit)