No Light through Glass

Hi,
I’ve got a problem with glass. The material works almost perfecly, but for some reason light doesn’rt pass throught. You can look through, but everything behind the window is dark.

There is one image attached with the glass aund one without, where everything “behind” the glas is visible. Has anyone got an idea what could be the reason, or how I could solve the problem?

Attachments



Make sure the materials have TraShadow turned on. (In the shaders tab)

It is turned on. Everything besides the IOR is exactly like in this tutorial

Make sure TraShadow is turned on for the materials that are inside the glass as well.

When using glass in a scene like your own, I usually hit TraShadow for most materials, if not all.

If your sure you’ve got it right, you could do a quick test by putting a light inside and see if any comes through.

That is the problem with Blender (opps I said that word). If you have a complex object like a cockpit, and you want to see inside, you have to select every frickin little object and turn on the TraShadow button in each material. Why isn’t this button just on by default?

It’d make more sense to have it on by default but its just one of them things I’ve got used to.
If I have issues with something through glass I check that first as its the usual culprit for me.