"No mesh or image found to bake to"

Yes, this has been seen many many times, but I’ve tried everything suggested here and on other sites and I STILL can’t find a solution to this little error.
It didn’t used to be a problem but in an attempt to properly bake textures and normals from a high-poly mesh to a low poly mesh, I exported and imported the low poly mesh into an older version of my high poly mesh.
Now, I’ve properly unwrapped the lowpoly mesh, I’ve created a new image, verified that the UV’s are properly oriented and that I’ve selected the High Poly mesh FIRST and the Low Poly mesh SECOND.
Both objects ARE renderable, and both are shown as renderable in the Outliner window.

For the life of me, I can’t figure out why I still get this error and what changed from when I was baking the textures before.

I’ve uploaded the .blend file here:

Any help would be greatly appreciated. Thank you!

On opening your blend file:
Press Tab to go into edit mode
In UV/Image Editor Window press the New button to make a new image (use the default settings)
In the Properties window I press the Bake Button
This gives the result below

This bakes the texture but you are also talking about high and low res versions of your model but they are not set up to bake any normal or displacement maps. What do you actually want to do ? The bake options are set to texture, is that what you want ? Please clarify.

Wow… Just did the exact same thing I’ve done 50x, but this time, it works!
It works with the save/downloaded version of the file, but not the original file itself.
File must be corrupted or something. Thanks for the extra set of eyes.