No Mipmapping Without Batch File - Multitexture Mode Not Working...

Hey. So, I’m almost finished with a new ability to disable mip-mapping in a BGE game without having to use a batch file. It basically checks to see if the game was run without mip-mapping enabled, and if it wasn’t then it relaunches the game without mip-mapping enabled. It’s not the best looking launch of a game, but it works. The only problem is that it doesn’t work with Multitexture mode - it’s only GLSL mode. Does anyone know why or how to fix this?

NoMipmapping.blend (526 KB)


Yeah for some strange reason it dosen’t seem to be working on multi-texture mode and works fine on glsl mode. i then use your script and modify it to force change screen resolution in realtime:eek:;).
i hope you can modify any game setting this way.
EDIT:
and this works on tex-face and glsl. not on multi-tex. possible bug?

Gah, I was hoping that this would work. It’s too bad that it’s not working on multi-texture mode, but at least we know that it’s not a problem with the script or anything, but a problem with the BlenderPlayer… Hopefully the developers will see this and fix the issue… And thanks for adding the screen resolution thing - I was thinking about that, but mainly I was working toward the mip-mapping fix. I’m glad that it at least is a viable solution for people who don’t want to run with a batch file.

This looks useful, and like saga said, you can add stuff that needs to be restarted.

It doesn’t work on multi-tex for me either.
Ex.

Hmph. Hopefully a developer will come along who knows about why this isn’t working (or even better, could present a quick fix), since this is pretty much finished - it’s just not working in multi-texture mode…

Okay, I submitted a bug to the tracker. I hope it gets fixed - this is a necessary feature, and fixing this would be a great help to the community.