No model in Render

Hello I am a new user to Blender, previously being a long term Anim8or user , and am now enjoying my experience with Blender, However, I have a Problem, cannot seem to render out my Reindeer model, when I try rendering all i get is a blank screen, although I can see a fully textured model in the viewport.

To test that the camera Was working properly and I had it aligned to the model I placed a basic Cube around the reindeer
The cube renders but the Reindeer still does not.

There is only one layer. Using 2.64

If you want I can upload The Blend file.

This is doing my head in at the moment and my hair is falling out fast .

Is there a basic switch I have not turned on? please help

Most common reason is you have set the object to be non renderable. You can look in the Outliner Window to see if the objects camera icon is greyed out. If it is turn it back on.
Other reasons.
Have you lights in your scene
Is you object on a layer that you have set not to render in the render settings

Thanks Richard for your reply I checked those items you mention, ie: Object is renderable, in outliner, there are lights, camera icon is on, and the layer is set correctly, But still no Deer appearing, The test with the cube i mentioned in my post clears the fact that the camera and lights are working ok. Every computer I try this file on gives the same result.

I have another file with a different Model and the Camera in Object mode that refuses to rotate or scale although I can grab it and move it about it refuses to rotate.

Other files work fine Its just thes two that refuse to co-operate.

Ok , now found an answer myself, Duplicated the object and found that both objects now appear in the render, delete the duplicate and the original is now visible.:RocknRoll:

I still have no answer to the Rotation issue in the other file. :frowning: