No module.....? :{


(Aksy) #1

My question would be stupid but I’ll ask it anyway.

For example I tried to use Eeshlos Lightflow script and when I pressed alt-p, Blender “says” no module called os…
All pyhonscripts send me same error "no module called dynoise"etc… :-?

PS. I use python 2.2.1

SOMEBODY HELP ME!!! :frowning: :frowning:


(nerddogs) #2

Have you set the python path in Blender?


([email protected]) #3

Hi Aksy,

if you have already set your python path,like nerddogs said,

then copy the "os’ module from the python2.0/LIB folder,
and paste it right in the blender (2.23 or publisher) folder.

do this with each module blender can`t find.

if you need the Dynoise module get it here:

http://www.stormpages.com/eeshlo/VariousPython.html

hope this helps,

      dale

(theeth) #4

I really don’t recommend copying all the python modules in the Blender folder, it makes everything really hard to maintain and it can possibly cause some conflicts.

Martin


([email protected]) #5

Theeth, your absolutely right! leaving those copys in the
blender folder, can cause quite a stir.

tho, sometimes it`s the only way i can get blender to find
some of the modules.
(Nmesh module for the unwrapper script and, the "os and
web browser module in your "Dynamica script)

any suggestions would be greatly appreciated:)

       dale

(theeth) #6

did you try typing the path to the Python lib directory in the Python button of the Info window (where all the other paths are) in Blender?

After you did this, update the user default (Ctrl-U) and it should always work.

Martin


(Fred_Pyo) #7

What about the “chunk” module? What where and how? Blender can’t run the IO suite because I miss that…


([email protected]) #8

It works! :smiley:

   thank you,

        dale