No Motion Blur?

Hi, I have a ball crashing through a wall but when I render it out there is no “motion blur”. Any ideas why?

Also when the ball hits the bricks the bricks fall down but they don’t fly forward from the force of the ball. How can I get the bricks to fly forward from the force of the ball?


On any object add a Always sensor, an And controller and then a 2D filter actuator, and change that 2D filter’s type to “Motion Blur”
EDIT: Sorry, I misunderstood your problem.

Bumping this. Anyone!

Thanks SolarLune. Yeah I saw that post but I don’t know how it will help me achieve the motion blur unless you saw something I didn’t. :slight_smile:

So frustrated with certain parts of Blender right now. :frowning:

Last week I tried to use the “Depth of Field” and it renders with hard edged artifacts so that stopped a project I was going to do and now this week I can’t get a nice motion blur out of the game engine.

I’ve found many parts of Blender are cumbersome and slow (except modeling) compared to 3DS Max. I didn’t realize this until I tried to do a fluid simulation for a company. It just crippled Blender while my friend could easily do the same project in Max in realtime and it didn’t slow down his computer at all.

Sorry, just really frustrating when you’ve spent hours on a project and you suddenly realize that you can’t finish it properly because of technical limitations (maybe my own :))

Still really love using Blender but I hope some of the current tools can be fixed/improved before adding new ones. DOF, Motion Blur, Fluid Particles Speed, Knife Tool, Render engine etc. etc.

So here is what I was trying to accomplish but it seems pretty futile now except for some difficult workarounds. If anyone has any suggestions as to how I can get my image to look similar to this Modo one then I’d appreciate your help. Thanks so much.

Most Important Problem
Need this worked out most so if anyone can help I would really appreciate it. :slight_smile: Can’t get Sphere and cubes to render realistic motion blur. (see modo image).

Problem 2

Cubes aren’t being pushed forward in front of ball.

Problem 3
When sphere is going through cubes the hole that is being created is smaller than the cubes diameter making it unrealistic. I tried many things including trying to change the Spheres “Physics Radius” to be larger than the sphere but that didn’t help.

If you’re going for a render, perhaps you should do it yourself - you could take two pictures, one with the ball shot through the cubes, and one just before that, and use GIMP to blur the ball between them.

If you want the game, you’ll have to find true motion blurring - the link I posted was by martinsh, so it’s possible in the BGE. Perhaps you should PM him for the script - he’ll probably help you out. EDIT: I’m interesting in motion blur, as well, so I’ll PM him myself.

For the second problem, try lowering the mass of the cubes - the smaller the mess, the easier it is for the object (the cubes) to be moved by the ball, making the ‘push’ more obvious.

As to the third problem,

  1. Make sure the sphere has ‘Sphere’ bounds settings on it, and then try changing the radius - it should work, as the Radius setting will only affect the physics should the object have a ‘Sphere’ bounds setting applied.
  2. Have you tried to change the bounding box size of the cubes?