No Objects or Images Found to Bake To

This is driving me f’ing crazy. I have no clue why Blender (2.71) started doing this. Yes, I created and saved a new image from the UV/Image editor and saved it. And it was working just fine 30 minutes ago. But I needed to regen a normal map. So I clicked ‘bake’ once more to redo it and was greeted with that damn warning. I haven’t changed anything and nothing will get rid of the error. Not creating/saving new images. Not changing the selection order of the two objects. Not restarting blender. Nothing works. What’s going here?

I’m leaning towards the “you still did something” answer, so if you’re able to share your blend file, please do so via and post the link to it.

But… If you really, really didn’t change anything yet, try unticking/ticking ‘Selected to Active’ checkbox. I’m only saying this because similar problem was mentioned recently on IRC but it was gone before it could be reproduced. If it’s really the case, we’d need to find a way to reproduce it reliably so it could be reported to issue tracker.

I tried the unchecking/checking already. It had no effect. I also tried unchecking – restarting – checking. Still refuses to do anything.

If you’ve been told the correct steps to take and it is still not working correctly, either you are not performing those steps properly or there is some other underlying problem with your model. So it would probably be best for you to post your model so we can confirm which of these two possibilities it is.

I haven’t changed the model. And it was working. But I needed a new set of bakes to replace an earlier set. It seems to be ignoring the selected image. I have the target image in the UV viewport, But when Bake is selected, it throws it out and returns to +New.

We can’t help you until you help us help you.

You haven’t changed your model from what? We haven’t seen this model yet. You haven’t shown it to us.

Never mind. I deleted the model and re-entered it. It works now.