No render output in scene/Objects not rendering issue/ Cycles Render

So I’m trying to create a short animation of a fish swimming through the water. I modeled the fish and gave it a material/texture. Then I added a lattice and placed it so that the fish would be inside of it because I wanted to add a couple of shape keys to provide that effect of a fish curving from side to side as it swims. I selected all of the parts of the fish and made them the “child” objects of the lattice (parent object).
I of course added the key-frames and previewed the animation in solid object mode. I can see the animation of the fish swimming whenever I am in any “method to display/shade objects” except for “Rendered”. Instead, I get a blank screen with none of the objects being displayed. Also, for some reason, whenever I try to render the active scene, I get a message saying, “No render output node in scene” and I’m not sure why. I did play around a little bit with adding a UV unwrap to my fish to give it some additional texture but I don’t see why that would prevent it from rendering. Is this the reason? I checked online to see if anybody else was having this problem or a problem similar to it. One answer said to add a input “Render Layers” node and connect it to an output “Composite” node through the “Image” circle. I tried that and I get either a blank grey scene or a black scene. To see if I really even NEEDED to include a specific pair of nodes, I opened a new project and checked the “Composite” mode and there were no nodes to be seen, YET when I rendered the cube, it rendered great.
I also ensured that I didn’t accidentally hide my objects and I wasn’t. I have a camera and locked it to the view (showing the fish) and I have a point lamp positioned directly above the fish and it’s in the correct location on the X, Y, and Z axis. I checked to see if I would have the same problem with any of my previous projects and even tested with a new project, and I didn’t. They were rendering as they should be so it’s not like there’s an issue with my graphics card or the program itself. As the title of this message suggests, I am trying to use “Cycles” Render.
ONE MORE THING, I noticed that this problem first began to occur when I decided to enable a World node to my scene (to create an ocean environment). All I did was try to make the world blue. When I did this, my fish disappeared in rendering view on both preview render mode and when rendering the active scene. All I got was the blue background so I tried unlinking the datablock but that didn’t solve anything-I just got a black background and for some reason today I get a grey background. (I started this project yesterday.)
It would be great if someone could help me out with this conflict. Thanks!

Hello rodey316,

Could you post an image or the file itself?
I don’t have any idea what could have caused your problem.

Thanks for replying, XxCentauri24xX. Sure thing, here are some screenshots of my project. Can you tell what’s wrong?


Attachments



Also, here are the other screenshots of my project. can you tell what the problem is? [ATTACH=CONFIG]371126[/ATTACH][ATTACH=CONFIG]371128[/ATTACH][ATTACH=CONFIG]371129[/ATTACH]

Hello again,

I’m not sure whether I should be able to see the problem or am just blind, but after ages of considering I can only think of two solutions:

  1. trying another Blender version (recently struggled with a bug with nodes, too)
  2. uploading the blendfile to check if this error(s) only occur when using your PC
    and avoid having to make a screenshot of every single window
    I don’t see any connection between a “missing” output node and a blank screen in rendered mode, because compositing is only relevant to real rendering.
    So there seem to be several issues.