no repeat texture?

i would like to turn off repeating in texture on 1 mesh
can i do that?

What renderer ?

For Blender Render, in the Texture / Image Mapping panel change it from repeat to something like clip
For Cycles use a Mapping node with Min and Max enabled

cycles
sorry that i forgot.

The cube on the left has Min and Max enabled, the cube on the right has them disabled


May I ask a related question as I have just stumbled into a similar problem and thought I’d save starting a new thread.
I come from a Lightwave background and there, you have 'edge / stop / repeat & mirror options for the image mapping.
Obviously the ‘standard’ is repeat with the above option creating the ‘stop’ action, however, how would one do mirrored textures and ‘edge’? (where the last pixel on each edge covers the remainder of the faces selected for the UV map). Or are these options not avialable in Cycles? (They all seem to be available in BI).

It repeats the colour of the last vertex. In the previous example, that last pixel was transparent. If not you get the result below


Is there any way to make it mirror? So instead of a pure repeat it is mirrored as it repeats.