No shadow ... Why

I created a model, put it in the scene on a low poly plane, added an angular map background and render all.
No shadow was made -why ?

Lamp is casting ray shadow and I set the plane to recive shadows only but no shadow is visible.

At the .jpg you can see renders before and after I set the planeto recieve only shadows.

Please help a bit !! :smiley:



The blend file:
http://www.pasteall.org/blend/19201

Post a .blend if you want help, too many things that could be wrong.

There are several possibilities to consider …

(1) “Hey, this is NOT ‘real life!’” (And that’s a good thing.) Some types of lamps don’t cast shadows. For instance, spotlights do. (And, some magical kinds of lamps cast only shadows!) :slight_smile:

(2) The material has to be set to “receive shadows.”

(3) The object that’s casting the shadow has to be visible to the light, and set to “cast shadows.”

(4) There are several algorithms that can be used for shadowing … basically cheap vs. accurate.

Any of these things can affect shadows.

So, as you can plainly see, “shadows are special.” And one reason why they’re special is that shadows can be expensive. A lot of your render-time can be soaked up in shadow calculations, even when the result of those calculations doesn’t buy you anything (at all, or that you care about) with regard to the finished image that you want to produce.

HTH …

I added the blend file (bottom of the topic).
I set some settings, usually I know what to do but now I’m darkened …

If you’re trying to get shadows just from an AngMap in BI it won’t happen. BI doesn’t support true HDRI lighting.

You have a shadow but it’s faint because of the Ambient Occlusion settings.
You can change the AO settings or in the Planes material Shadows Only settings change the ‘Shadow and Distance’ option to ‘Shadow Only’ or ‘Shadow and Shading’

Attachments


Of course!
Trivial solution ;|

About the AO I didn’t knew…

Anyway thank you guys !! :wink: