No shadows from my hair.

I am not getting shadows no matter what I try. I have looked over the material settings and the lighting settings and still my hair particles don’t cast shadows.

Not enough info, attach blend file.

Are you using strand render, if so you need buffer shadows selected for your lamp

Make sure you’re using deep buffer shadows, and make sure shadow clipping for the lamps is low enough that your hair isn’t inside of the minimum distance value. I ran into the same problem recently.

Here is my picture, and also the file. If some of you could have a look I would appreciate it. Thanks.

Attachments

Capt’n’s Hair Test.blend (1.06 MB)


This is a tex paint version with different hair… thoughts on that are welcome, too.

Attachments


Particle hair with a strand rendering can only cast buffer shadows, you have to use a spotlight for the shadows.
Either that, or you disable strands and use raytraced shadows.

The hair can be converted to a mesh, now this takes up a lot of mem. I think cycles hair, would be able to cast the shadow. But if its just a still image your looking for. convert the mesh delete the mesh the part system will still be there later.

In BI, it is true that enabling the strand render option will mean the hair becoming invisible to raytracing (so it won’t work with raytraced shadows).

It also means that you will need to use environmental maps for reflections as well. There is an alternative however if you need the memory advantage of strand primitives with the flexibility of raytracing and that is switching everything over to Cycles and setting the feature set to ‘experimental’ (recent trunk builds only, you will not find it in 2.65).

Though if you really need to use BI and have hair work with raytracing, then you should disable the use of the strand primitive and instead use the ‘adaptive render’ option in the particle panels. (which will automatically shave off polygons in sections where there’s not a lot of curving and where it’s straight).

I was using a sun lamp and the buffer shadow option wasn’t listed. I really like the sun lamp for a number of reasons. The spot lamp had the option of buffer shadows and it does work, but I am getting strange shadows. It actually looks like it is casting shadows of the hair in Edit mode… It also looks blocky or pixilated. I want to animate this character, also. Is Cycles a download separate from Blender or an ad on?

Check the engine menu in the top bar, when you click it on, change it from ‘Blender Render’ to ‘Cycles Render’. Cycles is an official part of Blender and will appear in every build.

Do note though, you will need a recent trunk build and the feature set set to ‘experimental’ to use hair rendering. (it’s not in the official 2.65 release).

The strand option was clicked in particles , BI will render hair shadows by default. Use some trans and a texture mapped to the parts and a little color ramp helps.

I have tried some suggestions but not the cycles thing yet. It is very important to me to have hair with shadows and translucent shadows for the helmet my character wears.

Attachments




The top pic is with buffer shadows and is blocky. I increased a setting that I actually don’t know much about , some samples setting from 4 to 9 I think it was and it improved, but not perfect. The second is with AO and a spot lamp, AO without a spot lamp looks awful. But it still has the same problem as the final pic… a weird blocky shadow effect that is leaving some strange effect under his chin. The pics are each a little different also because I am experimenting with tex painting.

The following pics demonstrate what I am trying to acheive.

Attachments




The top pic is the most recent and is with hair. I want hair and transparent helmet.The second is with a spot lamp. The third is with sun lamp.

Thanks for your help. I am using raytraced as explained by some of you. I am disappointed that it is taking 3 times as long, but I am getting my shadows from hair and transparent from helmet.

Attachments


If anyone has any more suggestions that would be great.

Attachments


i think you may have to stick with the raytraced shadows if you’re going to want the light to pass through the helmet, then through the hair to create the shadows. try using Adaptive QMC for the sampling method and tweaking the Threshold value. you can also adjust the samples to help out with render times, but anything less than 4 or 5 will start to become really pixelated. great job on this guy! i’m impressed!

Thanks Swirlypillow, for the advice and complement!