No shadows or light showing

hi, I have this problem that I have two objects and when I move around the light one receives shadows correctly and the other one does too barely but if I render it, there are none? Which setting did I mess up? :confused:
Same thing is going on with my other file. I have to separate objects and the hair is just acting weird… I tried flipping normals and recalculating and I can’t seem to correct this.

Attachments


Hi,

To solve the problem of the hair, apply it the solidify modifier to get a solid mesh. For the other issue, there are several settings to check up: Universe settings, material settings, rendering engine (Blender Internal or Cycles?), light settings.

thanks! Do you have any idea what those settings might be exactly? :confused: its just the weirdest things… I have gone back and checked to see if there are any problems but I didn’t notice any… :spin:

Hi,

Well, I´m not sure. Can you upload a copy of your file?

Have you set body material receive transparent shadows?
@LuisEDB: it says BlenderRender on screenie…
And really no need to solidify imho.

I see what it is… but my problem still remains :confused: here are the files.

Attachments

vic.blend (533 KB)


File problems… Blender 2.61? Something broken anyways.

yea that is exactly what I thought too… so can I fix it by making a new file and just importing the object?

No harmed pcs so far :). Try new file and Shift-F1. Hair (plane ?) did not for me.

I tried it and there is the same problem… I don’t know what the problem might be :confused:

If you just add vic mesh in a new file, then select faces on head which are where hair will be, shift duplicate and separate mesh,scale it a bit - it’s some half an hour work at maximum. $%^& happens. Here’s great tut on such a hair btw http://www.paultosca.com/varga_hair.html

Actually I have the same problem with the rest of the mesh lol… I made materials for the rest of the body and totally new hair (it looks so much better) and everything is still black… so I am really not sure what might be the problem. Do you want to see the file and materials again? Sorry :confused: this is just bothering me so much…

On the render properties pannel under the “Layers” tab you have to enable the render layer check box. Easy, simple.

Even now, if i download file and render, image comes out normally. Render layer has it’s tickmark. Except, there’s Plane/Plane.003 object, supposedly hair, which behaves badly. It’s seen in object mode, while in edit mode it’s non existent for blender.


Actually i did model new hair in the very same file and assigned materials both to hair and body. All turned out as expected. That’s why i suggested to do the same.
Now, it seems, you might have problems with Blender. Upload file, let’s see the differences.
I would suggest downloading fresh blender from GA and put in other folder to see if that helps. Since idk what os (win, nix) your’e on… I usually make folder named ‘config’ under 2.6x, then blender’s startup file is created there and could be different between versions (script paths, what’s on default scene and so on). On win you could run into some write restrictions…

Ok so its not the problem that RamboBaby suggested, that all is fine. But could it be the light? It might be that the object is fine but somehow there is no lights? Here are my new files. I just quickly painted those so it doesn’t look like much. I don’t have this same problem on any other file.

Attachments

vic.blend (553 KB)



This is what i get -

Had to take attachment textures - not in file.
No lower part tho. Transparency on vic object - why? It should be on hair only, or you have plans?

Btw this is what came out of 1st file with a bit of hairstyling. I would add some more mesh to it.

Oh wow! that looks amazing! is it a lot vertices? OK well mine is like pitch-black when Im in 3d view and in object and have it on materials instead of solid. The issue about legs I noticed today… for some reason they didn’t unwrap at all (even thought I selected all of it lol) can you try to pack the materials and upload the file so I can see if there is indeed problem with my entire software?

btw thank you so much for your help so far <3

Its just selected some top part of head Shft-D, then P to separate that. Then extrude here and there, take same steps on this mesh to get another part. Move, scale them as you like to make a bit of volume, texture in gimp. So it added like 50 more verts :). Horn - just material with blender’s texture bump. Renders slow since i put some sss on body. If you texture it, uncheck that. And sloppy hair drawing… just a test.
If you don’t see anything during render, that’s due “Full Sample” in render panel.

Pitch black with textures, GLSL and Textured looks like no lights on scene, dunno, on your last one i had to hunt for textures, but lights were ok.
And no prob with helping, i’m learning 2 :slight_smile:

http://www.pasteall.org/blend/11969

Argh, switch to GLSL and TAKE that Transparency off from body material in your file! lol…

One more - check Shadows - Receive Transparent for body.
And modeling part - select all body, remove doubles, separate upper body from lower part - there should’nt be this pants extrusion up - that doesn’t help unwrapping likely. It’ll be one mesh, just separate peaces.

So I just downloaded the file and its completely dark when it opens (I don’t click or change anything its absolutely black) :’( I don’t know what to do :confused:

As a last resort - one in cycles. Could you pasteall screenshot, showing N-panel Display parameters, shading mode for 3d window and what’s on it?