No sound when rendering an animation?

I added a sound clip and a strip of images into the video sequence editor and then selected avi raw and in post processing i selected sequencer. after rendering it the film works fine but there isn’t any sound. The sound works in Blender but not when it’s rendered into a film. Is there something else I have to do?

The video is also a bit jumpy and laggy for some reason. Is there another format than AVI raw that doesn’t make it jumpy? Or a way to fix it and make it not jump.


No sound: You must use the FFMPEG option (2.49b) or the MPEG option (2.57rc) in order to multiplex (mux) sound & picture from Blender.

Jumpy playback: AVI Raw creates huge files (as you may have noticed) because it’s uncompressed. This means that the player utility has to process large amounts of data and it’s choking trying to do that. Use a video codec to compress your movie and it should play back fine.

If you want to use the AVI container format, a choice for settings to consider is:

MPEG (FFMPEG) output format; video codec = Xvid, audio codec = mp3. These should do OK at the defaults to generate a muxed movie for you. But do some research into video & audio codecs so you can make your own choices in this regard, because different playback venues require different settings.

Thanks for the info. The only problem is that it isn’t working to get the sound in. Maybe I’m doing something wrong? I go to the render tab and select the MPEG option in the output tab. Then under it on “encoding” I choose xvid as the format and on audio codec I choose MP3. When I hit animation nothing happens.

I have a tutorial for this : edit: site is down, direct link to video:

@ blenderman911 – I’m also having some unexpected difficulty with 2.57rc2. Using specs I used successfully in 2.56beta, I can’t get anything, either – the error message (in the Info menu bar at the top of the UI), reports “Cannot initialize video stream” no matter what selection of settings I use under MPEG. I assumed 2.57 would work the same but apparently not. Unfortunately I ditched my version of 2.56beta but will d/l & try it just to confirm that this seems to be a new issue.

That error usually points to a missing codec problem, but I know I have the needed codecs for the formats I tried.

Sorry about the confusion, that’s just life as usual in Blenderland, especially during a development cycle.

EDIT: I did a few tests and found out one thing for sure – 2.57rc crashes more often when using the VSE than any other version I’ve yet used. It’s ridiculous. Nine times out of ten, after successfully writing a muxed file out, I switch codecs, hit “Animation” and boom, crash city. That is completely annoying. No reason switching to a different codec should cause that behavior.

And other behavior is very puzzling. I was able to use the following specs to successfully write a muxed file:

DVD preset with AC3 audio
AVI with MPEG-4 video codec and MP3 audio
Quicktime with MPEG-4 video codec and MP3 audio

I could not use the Xvid or H.264 video codecs without getting the error message noted above. This is very strange because when not using MPEG for muxed output, I can write silent AVI with the Xvid codec, and silent Quicktime with the H.264 codec. I know these codecs are on my system, as I have used them with other apps than Blender.

I really think Blender’s management of such resources as codec libraries is very weak and inconsistent. The whole subject is confusing enough without creating even more puzzlement.

I tried all those presets you suggested and none of them worked and I kept getting an error. So I decided to do it on a new blender file and it worked perfectly. I’m not sure what the problem was with my old file but it works now. Thanks a lot for the help I really appreciate it. The only problem now is that the audio goes faster than the animation so it doesn’t match up, If you know a fix for that?

Mismatched audio and video synch is often caused by using a frame rate that does not perfectly match the source video. Check what your source uses and set to the exact same figure in Blender. And it must be exact – 29.97fps is not the same as 30fps, even though it’s very close. Over hundreds or thousands of frames the difference adds up & is very noticeable.

Now I remember. I rendered the images at 30 FPS and forgot to switch to 30FPS when doing the sequencer. It all works now. Thanks a bunch for all the help, you rock!

I have the same problem I uploaded video to YouTube before that I used OpenShot Video Editor,but there’s no sound.Is it because YouTube prevents of copyright infridgement I was trying to edit this video,but I didn’t find original song.Do you know how to solve this problem?How to fix it?

Could it be fault of weak processor and RAM?My PC have Intel Core i5 3,10 GHz,4GB RAM and Nvidia GeForce GTX 1050 Ti.My younger brother told me that I should have little bit more powerful RAM disc and at least Intel Core i7 because Intel Core i9 won’t be compatible with my motherboard.

Guys sorry for post duplication, but it’s working.