No texture rendering problem

Greetings, I’m somewhat new to blender, and I have this problem.

I’ve imported an object, added an armature, and somehow made it invisible to texture rendering. That is, when I put blender in textured mode, I get a white void, like this:

In shaded mode, it looks like this:

There are no materials applied to the mesh. I’ve tried messing with the normals, but I don’t even know what those are.

I think I imported this object as a .obj. I reimported it and there wasn’t a problem, which makes me believe I somehow screwed everthing up while I was adding the armature, animating, etc.

Any ideas as to what’s causing this white void?

There are no materials applied to the mesh

how should it be textured then ? Press F5 and then add a new material

Hmm…I tried that. I added a texture (clouds), and while it shows up in shaded mode it’s still a white void in textured mode.

Textured draw mode will only display the UV mapped texture that you load in the UV / Image editor window. If would appear, your mesh has no UV map applied to it.

Figured it out. My light was on a different layer than my horse. Moved the horse over to the same layer as the light and that fixed it. Thanks!