No Vertex Shader/Radio mix in Game

Okay I just Know that there is one little button I need to press or something, but I can’t find it in any forum or tut about this. I make a model, apply UV texture to it, then use the radiosity to make some nice looking lighting effects (or just use the vertex paint brush, same thing…) And I’m sitting here with a pretty good looking scene and then I press ‘p’ and it all goes away… no more vertex shading just the raw unlighted/unshaded texture (e.g. it looks really really bright)… … What am I missing?

You have to be in textured view mode when you press “p”.

Yup, I am in Textured view mode- I can see the radiosity/lighting fine and it looks great but when I play the game it all goes away and just uses the unshaded UV texture with no lights.

Here are some screens: The first is just in Textured Mode… looks good — the second is while the game is playing…


go into face select mode,press A to select all(or double A) press W ->Light do this with all objects u want to be affected by light

Able, yes I did that and it didn’t change… see the image below… (Doesn’t the Light button just apply to real-time lighting, not radiosity, anyways…?)

Below is an image showing the texture face settings:


Why is your cube purple???

Because you have texture enabled but no texture. There will be problems if anything is that horrible pink color. Beware the Pink!!!

No the pink is okay because that cube is only the light emitter for the radiosity. They have the same pink cubes in the tut on radiosity here:

And anyways, lol, we’re talking about the WALLS not showing up as vertex shaded when I play the game, not the cube…

And would it have been so hard to specify that in the beginning?

Anyways, upload the blend and I will figure it out.

Thanks man, here’s the blend:

Okay, somehow I need to have two UV layers and do the radiosity to one and then mix it to the other… right…? How do you do this?


to make the cube appear:
make the cube material’s single-user, then disable the VcolPaint and add a Texture slot ( whatever one)
Now select the big cube and with material.001 selected enable VColPaint
Now, this is an “evil” method, TOO many faces for such a poor result
You can get more or less the same scene, dividing the cube scene two times, and adding a real-time lamp or “baking” the light to the Vertex Colors paint.

OTO, YES “baking” the light to the Vertex Colors paint is Exactly what I AM trying to do, how do I do this? I don’t want to use real time lighting I just want to bake it, but when I bake it and then play the game all the baking doesn’t show up… what do I do? See the screen above that is when I play the game? it has no baking or shading at all to it…

To bake light information to the object, select it press V key, then W key, ok in the popup, then V key again
You must do some experiments to get the good light
Each time you restart you must erase the old Vertex Color in the Mesh Panel
Enable the VCol Light
This can change if you use or not The “Use Blender Materials” option
OR…even more strong…you can bake shadows/textures to your UV texture
A little tut here:

I have fixed your problem. I don’t know why or how it worked, but I know what I did to make it work.

All you need to do is disable “Use Blender Materials” and delete the object’s link to it’s material. View screenshots below:
Proof I got it working.
There you go. (click thumbnails for larger images)

Niiiice Mr. Crunchy - Thanks! Does anybody know anything about this, why you have to disable use blender materials and delete the material link?