Node editor lagging a a lot in fullscreen mode, tiny scene.

Blender 2.69. I have been messing around with a procedural shader for a sort of cobble/mixed stone material with bump. The scene is tiny, three objects , 300 tris. When in normal gui mode I can scroll/pan the node editor at normal speed. But when I hit shift-space to go into fullscreen mode it is painfully slow. Any thoughts? Here’s the tiny test blend.

proc-stone-15.blend (802 KB)

seems fine to me
i can navigate in node editor with no problems

are you going to share this new stone set up ?

but if you have a midieval PC !LOL

happy cycles

Hmmm, It’s a weird issue. I have huge scenes, and the node editor is normal speed. But if it’s ok for you, not sure what to think.

Yeah, I was going to add it to the ‘yet another thread’ when it’s finished. But it’s about 30% done.

Right now I am on Win 7, but will probably be switching to linux soon. I have blender working on X, but I just haven’t fully made the switch. I’m still tangled up with Photoshop. The Gimp makes me sad, although I head there is a new ps style skin for it,

“but if you have a midieval PC !LOL” Not entirely sure if this a reference to the medieval stone shader or a swipe at my PC. Either way it’s quite funny.

Happy Cycles!

i mean i got an old 32 bits machine with a very cheap intel chips for video card
and it works fine i can navigate without any problem at all!

so just wondering if you still have an 8 bits machine may be!

there must be some setting somewhere !
but i know that if you zoom in a lot in node editor it will begin to get sluggish!
samething problem in uv editor image
so try to keep it not too big in node editor and it should work well i guess

on bigger machine i would say it should not be a problem at all

happy bl

I mean it’s a laptop, but it’s 64 bit with 8GB of RAM. It’s not the machine. It’s either the software,or more likely, the user!

Weird… If I slide the windows around so that the node editor is nearly fullscreen it responds just fine, but when I tab-space into true fullscreen it’s a dog.


i tried with shift space or with the arrow UP for full screen and seems ok for me on my small PC
so you must have someother settings may be

my machine is about equivalent to an I3
but do you have a video card too ?

salut

Ok, well thank you for testing it Ricky, I will have a look at preferences and see if I can find something. The shader is coming along slowly, still needs more noise.


looking good

how did you get the procedure text to give such nice bumps?

happy cycles

The basic setup I have used is just using a brightness contrast node to make the edges hard on the texture. In the shader I’m working on it’s a bit more complex, but this is the basic idea. The first 2 image are just color and third one shows how the bump looks.


i tought that the displacement was supposed to use intensity not color
but seems to somehow work fine!

i treid your last nodes set up on bottom right
and dont get same bumps
unless you use true displacement here

do you have a sample file for this
would like to this work well like that

salut

There is no true displacement on that plane, it’s all procedural bump. There’s no modifiers at all actually. When it comes to procedurals I just experiment. In my head, I do understand why this shader is looking the way it does, but it is difficult to put into words. And probably tougher to look at the nodes. The nodes are a mess, and I have not put anything in node groups yet, but if you want to see them I’ll post links. This is a work in progress and is not finished, but here are both the example file and the current version of my purple cobblestone shader.


hard-bumps-ba.blend (657 KB)

And purple cobblestone WIP


3 images per post, next post for blend…

Purple cobblestone WIP:
proc-stone-19.blend (830 KB)

it is very strange i have a test file for musgrave
and if size = 5 it does not work but if i change it to 2 it works very well!

not certain why !

thanks