Node Material Problem

I set up my nodes and as far as i can tell there correct but when I render I get something totally different.
set up:
http://img83.imageshack.us/img83/5558/aa2hx6.jpg

render:
http://img83.imageshack.us/img83/1452/0001zb9.jpg

I looked at this for the node setup: http://blenderartists.org/forum/showthread.php?t=74137

And I tried this earlier in a different project to blend two textures and it worked fine. What did I do wrong on this one?

Strange, not one of the used materials appear on the blade, but a completly different (as far as I can see), do you have an idea what material is that?
Is the blade just one mesh with one material (as it seem to me, because at links to object is 1 mat of 1 displayed), or is the whole sword one mesh?
If this is the case, there might be some trouble with the Material applied to the blade (lets say not the node material is applied there but some other of the handle or somewht)

The blade is one mesh with one texture. Everything that is not red is a separate mesh.
I also found out that if I click the node button in the material menu the color changes to red. So I think blender is using that material instead and not realizing that its supposed to be a node material.

I still have no idea why.

Have you activated the nodes, in at least one of the materials of the blade (At least at your pic it is, but just asking to make sure it is all right )?
Try removing the connection to the wrong material.

Have a quite similar problem->
http://blenderartists.org/forum/showthread.php?t=74813
but also no solution up to now