Node materials not mapping right

I’m trying to texture a sphere with various planet textures. The material that I’ve applied to the sphere is composed of two different textures: one for color, and another for the bump map. The bump map texture applies itself correctly to the sphere (I am using the “sphere” option in the map input tab). The colormap is a node texture that I’ve simply put through an ‘RGB to BW’ converter.

The problem is that this node texture won’t apply to the sphere correctly; it stretches over the sphere as through being projected from a plane onto it. It has the exact same settings as the bump map texture, they are even the same image, one just happens to be ran through the node editor.

Is there a way to fix this, or is it a node bug of some sort?

I’ve attached an image of my problem.


Do nodes support anything but UV? You are still on ORCO. I 'm just wondering, I don’t know.

I don’t know, but I’ve played around with every setting in that dialog (including setting it on UV) , and am unable to get it to map correctly.

Could you attach a .blend? I’m playing around a bit, but it seems that normally, a node material won’t behave differently than a normal material.

For what it’s worth, you can turn a texture to greyscale by going to Map To and selecting Neg, No RGB and turning that pink color to black too.

I’ve attached the .blend. I cant figure out how to pack an image with the blend, so you’ll have to load your own image in the node input. Also, I removed a bunch of crap from the file so it would upload, and made it easier to navigate, but it doesn’t seem to have changed anything.


Nodeproblem.blend (624 KB)

Select your half-sphere, switch to edit mode, select front view, press U key and select ‘sphere from view’.
Now you can use UV for textures. I attached fixed blend file


Nodeproblem2.blend (642 KB)

Excellent :smiley:
thanks a bunch.