Node Wrangler not working for me?

Good morning!

I’m following along with a tutorial and am trying to import four textures with Node Wranglers Add Principled Setup function. I select my four textures… and nothing happens. I was wondering what I’m doing wrong. I’m using Blender 2.90. Please see this screen capture:

1 Like

Change the MTL- to MTL_ or delete it.

I got rid of MTL -, and then on a lark I got rid of all the spacing in the texture name. Either way is still not working for me.

1 Like

And… I’m officially an idiot. I forgot to select the Principled Shader node before I added the setup. :slight_smile:

Thanks NewVisitor!


Glad it works!

1 Like

Hey i couldnt solve this problem what should i do?

Make sure your Node Wrangler add on is enabled.
Make sure you click the principled bsdf node before pressing the Ctrl+shift+T.

Hope this would work.

I did the Same thing!!! You’re not the only idiot! Thanks so much!!! With out you I would not have moved forward! So your mistake and post helped!

From 2 years later, you are not the only idiot, we all are! Same problem solved