Nodes and UV

I asked this question awile back but didn’t get an answer. I’ve been playing around with it and have been getting closer but it’s still not working right. I’m trying to add soot on a UV map to the back of this engine. For this example though I just painted a little blue on a alpha channel so you can easily see whats going on.
Any help would be greatly appreciated

Attachments


looks good!

Thanks!
I was looking for help but I can see now that I didn’t explain my problem. I can’t seem to find a way to add the uv texture without it changing colors(when adding the blue and yellow it’ll make purple). The other thing is because I used a softer blush the blue should fade to yellow but it fades to white with a hard edge. I think my node setup it very wrong but I’m not sure what to do about it!

Thanks!

so, you don’t want the colors to ADD, since yellow and blue make purple, but instead you want the texture to SCREEN the base color? I’m not entirely sure, but I think you need a different mixing method. http://wiki.blender.org/index.php/Manual/Material_Nodes#Mix_Node

I think he’s wanting an alpha over effect that’s uv mapped which can’t be done in the material nodes because the mix node doesn’t have the option to “use alpha” of the second input like it does in the composite nodes. It can be done in the composite nodes though via a map uv node and (usually) some sort of mask.

Yeah… An alpha over node is what I need for this. To bad there isn’t one in the material nodes like you said. I’m not set on doing it this way either, I just can’t think of a diffrent way of doing it. I just want to add soot to the back, a little dust on the bottom, and maybe a little rust here and there. Is there a good way of doing this?

Thanks again for your help

The image shows a split viewer in the compositor with and without the little “A” button enabled on the mix node. The button allows you to use the alpha in an image in the calculation. You can see that the lower part of the sphere is blue in the alpha rather than transparent as is the top because the a button wasn’t enabled for the mix node that shows on the bottom of the split viewer and the uv mapped image was rendered with a sky (zero alpha). Map UV isn’t all that great unless you use a build that has the material id pass ( www.graphicall.org ) because it maps the image to the entire object which is usually unacceptable when objects have multiple materials. You’ll still need to smooth the entire thing out (usually with some combination of set alpha, blur, scale, and/or dialate/erode) unless you like those jagged edges you see around the uv mapped image. Sorry but there will always be a 1 pixel border around the uv map with the currernt node unless you don’t mind distorting the uv map with a scale node (which usually isn’t too convincing). You just need to play around with it to find out if it’s right for your project.

Edit:
You can still uv map in the 3D window and uv/image editor while using nodes…just enable the Tex Face button on the material tab.

Attachments


Thanks for your help RamboBaby! I didn’t know you could do that in the composite nodes. I don’t think that will do me any good though. I think I’m going to try making a material with several procedural textures then paint a black and white map to use as the factor in the mix node.