Noise Node Normals Problem

I am probably missing something here but does anyone know why the noise node creates this shading issue? As soon as I get rid of it the normals work just fine.

Without the Noise Node:


With the Noise Node:

Because the sphere is relatively lowpoly and the smooth shadding just fakes a smooth surface the adding of noise just shows this low poly… you might watn to add a subsurface modifier… if you use cycles and enable experimental features this also coul be adaptive…

Ok but I was looking for an explanation on why the noise added break the smooth normals. I also know a modifier will subdivide therefore making those faces smaller and harder to see. I just wanted to open a discussion on why that is happening in case someone has a more technical explanation. Thanks anyway.

There are no smooth normals to break… smooth shading just smoothes the color of the faces across any sharp edges… if you add noise to the bump (also faked normals) then this colorsmoothing breaks…

1 Like

Mate I meant it breaks the illusion of being smooth and hides the faces abrupt direction change that’s all. And I know it breaks still the question remains on why technically it breaks that’s all. Thanks again for your time.

What up,

Have you applied the Normals auto smooth along with weighted normal modifier?

Hey man! As you can see the sphere looks perfectly smooth when the noise is detached. I unsure but I believe the weighted normal modifier wouldn’t do anything in this case (but I tried before posting anyway). I use it more for flat surfaces instead so it maintains the shading completely flat much better. It is great for hardsurface design.

Hm…that looks weird anyway

Could you share your full nodes? I’ll try to do the same to see whether that problem will be appeared in my own case or not

It is very simple it’s posted at the top. Nothing else. Just a principle BSDF plus the noise texture node through a bump node. You can copy the exact settings.

Aight, thanks. Is that sphere, right?

Yes a regular sphere with default mesh settings. Simply apply smooth shading. You’ll see is perfectly smooth then add the noise with those settings.

Okay, and what kind of rander are you using?

IDK… left side smooth shaded… right flat shaded… cyles, no modifier…

1 Like

Didn’t find anything strange in my case

Blender 3.1.2
Default settings

UPD: just have tested in Blender 3.5.0 - works fine

Can you share that file to see for myself?

Sure thing. Here you go:

test.blend (947.5 KB)

Thanks. So when opening your file it looks fine but if I add a sphere myself the problem shows up again. I have added 2 different test files. Test3 is your sphere but I added an area light so it’s easier as those HDRI are missing. In that one the issue is not very visible. Still there but almost not visible. In Test2 I create another sphere myself and did the nodes setup etc. Check them out and show me what you get. This is what I get. Blender 3.3.1



Can you please share your sphere blend file?

I did the same and it all looks fine tho

What Blender’s version are you using?

Seems to me as if you just forgot to add a subdivision modifier to your scene

The point is not having subsurface modifiers. Your sphere looks almost fine without it so with it it looks perfectly fine but the one I added does not look as yours not entirely sure why. Oh I forgot to attach the file. Sorry. Here it is. (282.9 KB)