Noisy Cycles X renders?

I’m getting a lot of noise in Cycles X (Blender 3.0.0). I found no tutorials to address that. I found some tutorials on the older cycles. But some settings are no longer there, such as adaptive sampling.

Has anybody found a solution? The images are 1920x1080 animation rendered to png 16 bit. Very blocky noise in the shadows.

image
image
image

As it’s animation, the noise moves and jumps around, so it’s very noticeable.

Thanks in advance for your help.

1 Like

Does increasing max samples makes it noisier? Because it seems 128 is less noisy than 1024 (above). I would have thought the opposite would be true. The same is true regardless if rendered in 2K or 4K. But that doesn’t fix the problem. It seems it is just blurring the noise. But in an animation the blurred blotch still moves around.

1 Like

Hi hi!

Noise is very dependant on the way your scene, lights and materials are set up. A single poorly set up light or material can cause a lot of problems, however sometimes it is just the nature of a scene that makes it very noisy. For example indoor scenes with small windows, where the lightrays get stuck in the room and bounce around a lot, scenes with volumetric materials.

Adaptive sampling is now called noise treshold, so that’s the setting you’ve been looking for.

image

That said, it’s difficult to help finding what’s causing the noise in your scene, without having access to your .blend file. Avoid creating mesh lights with a very strong emmision material, avoid very tiny lights/mesh lights.

Max samples should definitely not make it more noisy, and if it does, it seems like there’s a problem that can be mitigated in your scene somewhere.

Worst case scenario you’ll have to brute-force it and increase the samples enough for the denoiser to produce consistent results between frames.

2 Likes

Thanks for the reply.

I have no mesh lights or tiny lights. I have the sun, a couple of spots and area lights. None of them tiny.

The scene is indoors. It’s a low key lit scene, so lots of shadows. It’s mainly dark and objects backlit etc.

I have increased the samples to like 4500 and it’s still the same noisy results.

maybe fastgi additive mode can help you get rid of some noises… adjust AO factor and distance to get some little ambient light in scene.

1 Like

Any chance you can provide a blend file , maybe if you’re not comfortable sharing the full project just a rough blockout of the scene with just the lights you’re using copied into that new blend file? I’d make one myself, but from the provided images it’s very difficult to tell what’s going on in the scene.

1 Like

Thanks. This is what I’ve been trying to do. But since it’s a dark scene, adding enough AO to solve the problem means totally changing the mood of the scene, as it then becomes too bright.

I can’t really share the blend file. I could try to put together some blocky version. But it’s such a complex scene with lots of models.

All together I’m really surprised with this noise. Disappointing. I’m about to revert to 2.93 to check if it’s the same there.

Did you increase MIN samples?

Your screenshot looks like a problem I had from adaptive sampling was first introduced all the way up until today’s cyclesX. The only solutions were (a) disable adaptive sampling or (b) add enough minimum samples value or (c) significantly increase the amount of light in the scene and then darken it with the Exposure setting.

Basically not enough light is getting to those areas and the denoiser has no idea what to do with that lack of information. But there are also times when a lot of light is getting to the problem area and it continues to look ugly after denoising. In that case more minimum samples or disabling adaptive sampling is the only fix that worked for me.

1 Like

Have you tried what LanderVR suggested here?

Specifically, lowering it (for example, 0.1 to 0.01, or 0.01 to 0.001).

edit: example gif, with max samples: 4096, min samples: 0, and noise threshold: 1, 0.1, 0.01, 0.001

NoiseThreshold0

1 Like

Yes, I indeed tried it. From 0.01 to 0.001. It did help somewhat. But I have not rendered an animation to see if the area will still move around.

Thanks!

This I did not do.

But I think I’m having the exact same problem as you. Sounds exactly the same.

In Sampling > Advanced, try turning off Light Threshold by setting it to 0, just in case?
image

Ok, just rendered a couple of frames. Doing the above, despite looking less noise, the shadows still move/oscillate from frame to frame. Almost as if it was lit by candle light or something.

Activate Seed
seed

1 Like

If you can and don’t want to go crazy with samples, try filling out the dark shadows with some additional direct lighting. I sometimes use a tiny hint of global AO, and that additional brightness can help bring the denoiser artifacts down. Lighting mostly with low intensity indirect have caused issues like these for me in the past. Or render out only problematic areas with more samples.

1 Like

Thanks. So, just activate it? Or do I need to play with the parameter?

Thanks. The level of noise is ok when lowering the threshold. The main problem now is the oscillating shadow.

What should fix it is as Thinsoldier and Carlg suggested, add some more ambient light so the denoiser has more information to work with and can achieve a more accurate denoised result, and then bring the exposure down or adjust the image in the compositor to achieve a more contrasty/darker look.

I would like to look at the image