non-Latin languages (shortcuts do not work at all)

  1. Ubuntu 14.04, clean installed
  2. English (US) + Greek
  3. (Left) LShift + (Left) LAlt
  4. Unity
  5. Blender v2.7

When I use English keyboard layout I can use all the shortcuts (except some that use the Alt key, but that’s a Linux problem. For example Alt + (Middle) MClick (or button 3)). But When I switch to Greek, I can use only the numeric shortcut (Ctlr + 1 for example).

There are more applications with the same problem, so this could have something to do with Linux or Ubuntu in particular.
Any workarounds?
Should I disable keyboard Layouts when I use Blender?