Non SLI/Crossfire GPUs causing OpenGL 3.3 context errors in 2.8, wont launch

This is an ongoing issue I’ve been having…

First, the link to the bug report

I’ve found that running either AMD GPUs (2x RX480) or Nvidia (2x GTX 1070) while not in Crossfire/SLI, that blender won’t launch. I get an OpenGL 3.3 context error.

image

I guess I’ll just start with questions. Is anyone else running multiple consumer GPUs NOT in crossfire/SLI and using both for video outputs? Is it working with 2.8?

Just tried it on Win 10 with latest NVIDIA drivers. (Normally using Linux)

Setup:
ASUS ROG Strix RTX2070 -> Displayport -> LG [email protected]
ASUS RTX 2070 TURBO -> Displayport -> LG [email protected]

Blender: latest Buildbot
Scene: bmw27 GPU

starts, loads and renders just fine.

The (awesome) blender devs found me a workaround. I have to right-click the launch Icon and restrict blender to running on one GPU, which only impacts the viewport, if I’m understanding it correctly. I can still Cycles render on multiple GPUs.

Hm interesting, but I’m glad you found a solution.

What was it defaulting to? I didn’t know there was a way to launch on multiple video cards (except when in SLI mode and it looks like one card). Generally nobody uses SLI for 3D. You want the devices to be independent so they appear as two separate CUDA/OpenCL devices for rendering (which won’t work in SLI mode).

Maybe you have the SLI bridge cable in place but SLI disabled somehow and that’s confusing it. Unless you really need the SLI for gaming etc. I’d consider just disconnecting the cards from each other.

What was what defaulting to? I don’t know how blender is trying to start under the hood, and how it’s handling multiple GPUs. I also didn’t know there was a way to restrict blender to running on a single GPU, which is the fix for now.

I was using the SLI bridge because blender wouldn’t launch at all with two independent 1070s. The SLI bridge was an experiment to work around the no-launch issue I was having. (I had the same exact issue with a pair of RX480s, which I set up not-in-Crossfire)

The cause of the issue is still unknown, the devs suspect it to be a driver conflict between Windows and the GPU drivers, but the work around works, so I’m all good.

I was just curious what the default setting was for what they had you change. Was it right-click and "Run with graphics processor -> " in which case what was the (default) setting of that?

As far as I know, 90+% of people with multiple video cards simply have them installed as two independent devices and never encounter problems, so your experience that Blender would not launch in that configuration seems likely to be very unusual, and probably caused by some system driver or configuration or hardware issue.

Oh. Right. It’s “Render OpenGL on” which opens up another context menu where you can pick which video card you want to use.

1 Like

Cool, I didn’t even know that such a context exists. But then I usually start Blender from the command line anyway.

Just to follow up on this topic a bit, this morning I grabbed my RX480s and threw them in, got everything up and running but interestingly, the right-click “Render OpneGL on” context menu is missing. Curious… :thinking:

Maybe that entry in the context menu is provided by the NVIDIA driver?

Edit: that would explain why I never noticed it, since I’m coming from AMD just about two weeks ago.

I’m not all that familiar with the command line, outside of diskpart which is about all I’ve ever used it for. I tried launching blender from the command line, I get the same OpenGL 3.3 error as if I just clicked the shortcut on my desktop. Do you know of a way to force it to run on just one GPU via the command line, in the same way the NVidia jobbies allow?

Hm? Thought you said it’s up and running?

No, sry I am not aware of such a parameter since I never had such trouble and a quick read in the manual doesn’t seem to provide something useful.
You might try to start with

--debug-value 256

Just a shot in the dark. Since you can use NVIDIA and AMD together with it.

Sorry, failure of articulation on my part. I just meant I got the system up and running, all six monitors, no crossfire, everything else is working…just not blender.

That threw this back at me;

Hehe, sry. It should read

blender.exe --debug-value 256

I might have found the actual cause of this issue, though I’ve not tested it on a dual AMD system, I stopped getting the Open GL 3.3 errors on the Nvidia cards.

I tracked the problem down to using the HDMI output on both of the GPUs. I have the main HDMI going to my main monitor, then I was using the second HDMI to go to the TV on the wall. This weekend, I unplugged the TV so I could work, and the wife could watch TV without me losing windows (blender always opened on the TV screen)

I’d be willing to bet this would be a fix on the AMD cards as well, and I may test that if I get time.

1 Like