Noob: Extrude vs Translate

Sometimes when I try to translate edges or vertices, blender seems to make new edges/vertices and move them as if I am extruding. It would almost seem as if there are two vertices in the same location and I’m only moving one of them. I have tried to use the remove doubles feature, but it never removes any vertices, perhaps I am unable to select both the vertex and it’s double since they are on top of each other. Perhaps I’m just using this tool incorrectly. Any preventative advice is welcome as well if it sounds like this is a result of bad practice on my part. Thanks!

For remove doubles to work properly, you need to have all the vertices in the area selected (it only performs the action on selected vertices)
Try box selecting(B-key) the area in wireframe mode and then using remove doubles. Also it might be worth checking the threshold setting on the remove doubles tool.