Noob problem

OK, I guess thats the right place for that. I’m using Blender for 4 days now, so please don’t mock me.

I encountered a problem just now.
I finished my model of a medieval helmet and wanted to do some optimising and reducing the number of polygons.
I selected 1 object, zoomed in, dealt with some edges and vertices, zoomed out and noticed that all objects except the one I modified disappeared. I thought I maybe clicked H by accident, so I clicked ALT+H but nothing has changed. All objects are set to visible. Then I tried to use UNDO with hopes they will come back but no, it got worse, the only object I had disappeared as well.

I dont remember doing anything else besides checking edges and dissolving them.

At first it looked like everything got deleted, but I noticed that it shows Proper amount of tris. After some more fun with undo/redo and checking different objects it now shows 0 tris ( undo certainly didnt go back to the beginning as it doesnt remember that far back ).

I thought maybe the camera spazzed out and it just isnt in the FOV but when I check my background images they are just where i left them.

I can add new objects and they work just fine.

No, I wasnt saving my Progress :D:D:D:D Lesson learned.

Attachments



helm2.blend (522 KB)

Good that you included an example file but the full interface screenshots already reveal the likely cause: you’re in local view, indicated in the top left corner. Numpad_/ to toggle. That isolates selected objects from everything else.

I actually solved it by accident now. All I had to do is add a new screen and the model appeared. I dont know why that happened, why it fixed it, why it broke but it works again.

When I added a new screen everything got fixed. I have no idea what happened but at least I got the model back.