Noob question: BGE quality loss in depth

Hello everyone,

I got a VERY noob question about a displaying issue on my BGE. It shows fine in textures near to the camera, but it suddenly drops quality after a certain distance.

I’ve been a lot of time without Blendering and I think I solved this in the past, but I can’t remember how I did it.

Here is what I am talking about:

As you can see, it has 3 different levels of quality, easily differentiated.

I’m aware this must be one of the noobest questions about BGE, but I couldn’t fix it and I’m getting disappointed by myself lol.

Can anyone explain me how can I solve it?

Thanks in advance, and if some mod thinks this is useless, please delete the thread :stuck_out_tongue:

Kindest regards!

It looks like it might be mipmapping. You can either try disabling mipmapping, or enabling anisotropic filtering. Both options can be found in Blender’s system settings (ctrl+alt+u).

You can also mess about with your graphics card settings. If I recall, upping the anisotropic filtering, as Kupoman said, should be helpful.

Yeah! Thank you very much dude, it was the mipmapping, I didn’t remember about it. I was just playing around with anisotropic filter, but it just “reduced” that effect a bit (increased distance of quality loss), not fully removing it.

Thanks again :slight_smile:

Thanks for writing SolarLune.
It seems anisotropic is just taking the distance a bit further, but doesn’t even make a “smooth” mixup between good and bad quality.

I suppose I will finally have to use mipmapping with corresponding textures to have the “best” quality, right? or should I try something different? (I’m really outdated of graphic’s world :frowning: )