Noob question: how to fix this UV unwrap

Im very noobie at UV unwrapping.
I kinda know the basic principles, but im running into some issues with this unwrap. I want to add a specific texture (words) to a certain part of my shape. I selected the area that it needs to go on, and I pressed Unwrapped. So im getting this UVMAP, which is bended. I know, for a good result…i need to make it a nice straight horizontal line with rectangles right?

I saw in a tutorial that I need to ‘fix’ 1 rectangle, then select the others ones and press ‘follow active quads’ to make all the faces rectangles.

But I run into 2 problems… as soon as a want to fix one face… there’s a vertex in the left bottom border that moves along with it. I thought I accidentally selected this, but after redoing the selection it still appears. So i cant fix the rectangle properly.

Secondly… when I select my main face, and press L to select the others… ‘follow active quads’ doesnt do anything at all. nothing happens.

Can anybody point me in the right direction?

Hi!
try to unwrap the whole thing using Tube Unwrap


After that you can just find the UV part of your interest.
Also I think UV highlight will help you in this.

(scroll down to the bottom of the page and you will find the latest version in a comment)

UV mapping in pure Blender is a bit tedious and time consuming, you will need a bunch of addons to UV unwrapping.

Ill definately try that, thank you.

But regarding that vertex in the bottom left corner…do you know what that is?

If you can upload the file I think I can fix this within minutes.

Thats very nice, here is the file…
But can you also please explain what you did to fix it? So I can learn from it…

PS… i have cleaned up the file, and copied it to a new file to share with you. But I noticed the vertex in the left bottom corner is gone now… so thats good…(wonder what it was)…

The only problem im having is that when I fix a quad, and select the others… the ‘follow active quads’ is not doing anything…

http://pasteall.org/blend/index.php?id=52914

I will explain later.

Thanks for the file…that’s exaclty how I wanted it…but i stll dont know what you did exactly. Other then I see that you made seems around the area.

I tried that…but the ‘follow active quads’ command is still not fixing the distortion in the faces…

can you tell me how you did it?

There are internal faces in your figure 8 mesh. Switch to edge mode, do a Select -> All by Trait -> Non-Manifold. This may select a “good” outside face, so switch to face mode and deselect it and any other good faces that might be selected. Then delete faces. After that, select everything and recalculate normals. Then the Follow Active Quads and any other topology-dependent tool will work as it should.

Thank you for your reply @Stan_Pancakes

Im new at topology, so can you explain what internal faces are? (are the just faces that are inside the mesh and have no real function?)…and more importantly…how can you know that you have them?

you give me the solution to fix them…but how did you even know I had them? Or is this standard procedure to check this topology before you start working with it? Something like

  • check for doubles
  • check for internal faces
  • check for normal orientation

thanks!

Any face that’s connected to more than one other face at the same edge may be called “internal”. It’s impossible geometry, which will break or limit the logic of most of the tools, since it becomes impossible to determine which way the topology goes or “flows”.
In this case they’re literally internal, i.e. are inside of your mesh.

You learn that you have them exactly the way you’ve stumbled on it: tools stop working, or start behaving in strange ways - pretty good sign that something is wrong with the mesh. Then it’s just a matter of actually finding them - select non-manifold in edge mode is a good litmus test, as well as plain visual inspection in wireframe/x-ray view.

And yes, it is common practice to do the things you mention, and quite often to simply anticipate them (so as to not even have to do them) - once you get accustomed to how the various tools work and what results they produce, it becomes pretty easy.

Great I get it know. I just need to condition myself to optimize the meshes before I start doing anything. Just make it common practise.

Thanks a lot for your great explanation Stan!

@Stan_Pancakes tan_pan

ok so I tried it out and i run into this problem

There’s that little dot again in the bottom left corner…that moves with my vertex when I move it around…
When I select this vertex in the uvmap, it shows me the face in the mesh that I didnt select when unwrapping

And additionally… the image texture is really stretched when I view it on the actual model. (i did scale it first)…

Do you know what causes this?

Are you using the “Keep UV selection in sync”? That would explain this behavior.

Yes that was the problem! Everything works as it should now.

And as a small follow up question… I could I ‘extrude’ or ‘inset’ this text a bit from the object? Give it some height? I tried adding a bump node to the image texture…but thats not giving me a decent height or a good look (maybe i connected the node wrong)

Or is there a better way to to this? Im trying to achieve this effect. Which looks very smooth and has a nice inset.
pickpic 2020_025

Could be that the bump is just too strong and/or you don’t see the effect due to your lighting setup.

Ill try some more with the settings then…

so the node tree is correct for this? thanks

Yes, the tree is fine. Another thing to check since you’re using a .psd is what are the actual color values in the transparent area. If it’s also white you won’t be getting any bump at all, or rather, it will all be uniform.