Noob question on multi-res + mirror

Hi. I just got started with Blender some two months ago, and I’m running into some inconveniences using the multi-res modifier with the mirror modifier.

First, when using sculpt mode in this scenario, the intersection of the model with the plane of symmetry tends to develop ridges which appear really hard to get rid of due to the inability to use smooth across the symmetry plane.

I tried applying the mirror modifier to get a whole mesh, but for some reason in doing this I lose any changes I made to the subdivided mesh and end up with what I’d have with only one level of subdivision.

Any help is appreciated.
Thanks in advance.

You should apply the mirror before sculpting, and then sculp with x symmetry on.

Well, I know that now.
The problem is that I now have a pretty complex sculpt with both modifiers on and I don’t know how to get out of this.

I tried removing the mirror modifier, duplicating the mesh in object mode, mirroring it on the X axis, joining both together and removing duplicates, but in doing so all kinds of weird arise.

First, both halves of the mesh have a different base shade. I tried applying the same material to all of it, and it still looks like two separate halves.

Also, the center edge has imperfections, in the form of sharp protruding or inset segments which I wouldn’t know how to get rid of other than going into sculpt mode and smoothing them over and resculpt whatever was there.

Any help is really appreciated.
I’m pretty much a noob (just got into blender not two months ago) and I’m working on a model I hold dearly, which is what got me into Blender in the first place, so please bear with me.

Now, here’s a screenshot of what the problem looks like.

http://img196.imageshack.us/img196/9158/0fk2.jpg

Thanks for helping.

Anyone? Please?
I guess if I could only get rid of the coloration difference, whatever it means, I’d be OK with it.
The seam I can fix one way or another.

Hard to tell where you’re at. You could try selecting all verts and recalculating normals, although it looks like a material issue.

If that doesn’t work post the blend.

Thanks for your time.

By getting rid of all materials it seems like I got rid of the different coloring.
Now, getting rid of the seam in the center proved not to be as easy as I thought.

Here is a simplified version of the Blend file.
The actual file has a lot more work put into it than what’s visible there. Otherwise, I’d forget about it and start over.

I’ve already removed the mirror modifier, duplicated the mesh, and mirrored it.
To reproduce the problem, you should now select both copies, CTRL-J to join them, go into edit mode, select all and remove doubles.

The center seam will become a mess, and using the Smooth brush in sculpt mode won’t do any good.

Again, thanks for bearing with me.

you should’t have deleted the mirror. duplicating the object has messed up the normals so now when you join the two meshes half the model has backwards normals and re calculating inverts the sculpt, making it look horrific. you might have gotten lucky if you simply applied the mirror modifier. if you can go back to a older .blened before you deleted the mirror, then do so. turn the multires off ( with the eye icon in the modifier, don’t delete it!) then select the mirror modifier and press apply. that should preserve your mesh normals and you wont have to join two mesh object together. then turn on the multires again and see if your dtail has been preserved. if your lucky, it will if not, try moving the mirror up or down the stack before applying it, and see if that helps. i suspect you will be starting over though.
lesson learned, well done! :RocknRoll:

What I uploaded was just a test file.
I do have the mirror in my actual file.

Turning Multi-res off did nothing. Applying the Mirror modifier having it turned off lost all of the sculpting done to the higher subdivision levels, just like it does when you apply it with the Multi-res enabled.

Trying to move the Mirror above the Multi-res says “Cannot move above a modifier requiring original data”, and doing it the other way round says “Cannot move beyond a non-deforming modifier”.

There’s no way I’m starting over. Worst case scenario, I apply the Multi-res and the Mirror afterwards.
I lose my low poly version, and weight painting it will be a nightmare, but I keep the hi-res model in perfect shape, so it beats having to start over.

That said, it’s not something I want to do, so suggestions are still welcome.

@Small troll / uKer

Why can’t you just do this:

  1. Delete model.001
  2. Add a mirror on the model (after multirres) enable clipping.
  3. Apply the mirror.
  4. Continue sculpting, with x symmetry?

No seam, multi-res copies fine, the normals are good, What am I missing here?
Like this:



Thanks for your reply.

What you describe is what I have in my actual file.
The problem is that the mirror modifier has a couple of inconveniences:

  1. Sculpting is quite tedious as mirror is not supported in sculpt mode so you only see half of your model.
  2. I can’t texture it, since UV unwrapping messes up badly with the Mirror modifier on.

For these reasons I was trying to get to working with x-mirroring enabled in both edit and sculpt mode, while retaining the low-poly version for weight painting, and the high-poly in order not to lose all the sculpting I’ve done.

Again, I’m quite a noob at Blender, so there may be other ways to go forward than what I’m aiming for.
I’m totally open to suggestions.

Welp, you messed up pretty badly. This solution may or may not work, and the viewport performance will probably be horrible throughout. If you don’t care that much about your top multires level, I’d suggest you drop down to a lower one, but it’s up to you.

  1. Apply the multires
  2. Apply the mirror.
  3. Duplicate the object
  4. Add a decimate modifier to one of them (lets call this object A)
  5. Set the decimate to unsubdivide mode, then shave off as many levels as you can, but make sure the number of iterations is even.
  6. Apply the decimate
  7. Add a multires modifier to Object A. Add enough levels to the sculpt to match the polycount of object B exactly.
  8. Save to a new file at this point
  9. Select Object B, then select Object A
  10. In the modifier panel, on the multires, press Reshape.

If you’re lucky, you have a perfect multires object at this point. If you’re not, you have a blown up mess because the indices don’t match. All is not lost though, go back to point 8.

  1. Put on a shrinkwrap modifier on object A, set it to project mode, and select object B as the target.
  2. Tweak settings to taste.
  3. Apply the shrinkwrap.
  4. Delete object B

This solution might lose you a little information in the sculpt but not too much.

Uker, don’t sculpt with mirror modifier then. Just sculpt the full mesh and delete half before you start painting weights, UVs, etc.
> Delete left half of mesh
> Select Right half
> Snap 3D cursor to Selected (Shift + S > U)
> Set Pivot Point to 3D cursor (.)
> In edit mode, select/duplicate all verts (Shift + D)
> Scale -1 along x axis (S > X > -1 > Enter)
> Flip normals of selected portion (should have left side selected)
> Select all and Remove Doubles (W > R)
> Merge additional verts which were missed by Remove Doubles
> Sculpt with x symmetry on.

Like I said. You can always delete the left half at any point, but you wont have any modifier compatibility issues this way. Try out what I mean HERE.

@dlax, that’s what I said I did at the beginning of post #4. It’s not working out. Thanks for the reply anyway.

@Piotr Adamowicz Thanks for your reply. I like where you’re going. If I’m understanding right, you’re trying to work your way back to the low poly version of my model, right? If that’s the case, I don’t have the mirror modifier applied. I could easily duplicate my mesh and remove the Multi-res modifier to get to the low-poly version. I’ll try following your guide using this and see where it gets me.

Also, something I’m noticing is that for some reason, while the low poly version is OK, in the subdivided versions the multi-res is creating vertices that cross the boundary of the mirror modifier, so when you apply the mirror, there’s stuff like this going on, which I guess is the cause of the issues across the seam.

The problematic vertices are easy to isolate using “select non manifold”, but I’m not sure what to do with them yet, as simply removing them will probably change the face count and break compatibility between the two versions of the model.

Uker, what is it that you want? In post #3 you say that you want to work off a complete mesh and sculpt using x symmetry. Did you change your mind? I’m confused about how the solution is “not working out”. Both Blenderallday and I have given you solutions which put you on the correct workflow. What is it you expect to be happening?

Also, something I’m noticing is that for some reason, while the low poly version is OK, in the subdivided versions the multi-res is creating vertices that cross the boundary of the mirror modifier, so when you apply the mirror, there’s stuff like this going on, which I guess is the cause of the issues across the seam.

That is because you keep trying to sculpt with 2 halves instead of a single, symmetrical whole. Forget about the mirror modifier, remove doubles, merge the verts which accidentally crossed the central axis, and continue sculpting with x symmetry.

The problematic vertices are easy to isolate using “select non manifold”, but I’m not sure what to do with them yet, as simply removing them will probably change the face count and break compatibility between the two versions of the model.

Just merge them with their mirrored counterparts. If you took the time to open the files BaD and I uploaded, you would see that this is a non issue.

I was assuming you had all your border verts on the centerline so there weren’t any nonmanifold verts after applying the multires and mirror. If you have nonmanifolds you should fix that before proceeding with my method. Assuming your mesh is generally sane, just turn on ‘merge’ and ‘clipping’ and move your centerline vertices around until they stick.

In general, unless they’re just open edges, nonmanifolds are /bad/. Don’t ever tolerate any except if you need them for construction purposes and intend to fix them ASAP.

As I said in the OP, applying the mirror modifier loses any sculpting you did to the higher subdivision meshes.
I’d rather avoid that.

I still want what I wanted in the first place:

  • Get rid of the mirror modifier
  • Not lose the low poly version (meaning no applying the multi-res)
  • Not lose the changes I made to the high res mesh (meaning no applying the mirror)

I know non-manifold vertices are the devil.
As I had said before, the cross-boundary vertices weren’t there in my low poly version or in the higher order mesh produced by the multi-res.
They only appear when you remove duplicates after joining both meshes, that is, when both halves effectively become one mesh.

The problem appears to be that the normals in both seem to be going in opposite directions or something.
If you recalculate the normals in the merged object, the low poly version of the model in edit mode is fixed, but when you go back to object mode, you’ll see the multi-res modifier has gone nuts and now the edits appear either inverted (creases become ridges) or multiplied (bulges become HUGE).

You can see all of this by opening the test file I uploaded earlier.

Just:

  • Select both halves
  • CTRL-J to join
  • Enter edit mode, select all and remove doubles. The seam will be all funky.
  • Recalculate normals. The seam will go back to normal.
  • Go back to object mode. The crease near the hip bone will now be a protruding ridge.

Stuff I tried:

  • Recalculating the normals of the original object before duplicating it
  • Recalculating the normals of the duplicate object before joining it
  • Recalculating the normals of the object resulting from joining both meshes
  • Inverting the normals of the duplicate object

None of that did any good.

If you only select the faces around the seam and recalculate the normals of those, the weird seam shifts one edge loop into the duplicate mesh’s side.

When I get the chance I’ll see if I can follow the guide you posted before with the low-poly copy and using Reshape in the multi-res.
Let me see if I followed: the idea is to get the low poly and the high poly side by side (no problem there I think), select the low poly, then the high, and press Reshape in the multi-res in the low-poly model, having subdivided to the same level, right?

Uker, you didn’t follow my directions. I accomplished what you are asking for:
• You will not lose multires data.
• You will not have a jaggy line down the center.
• You will no longer use a mirror modifier.

Stuff I tried:

  • Recalculating the normals of the original object before duplicating it
  • Recalculating the normals of the duplicate object before joining it
  • Recalculating the normals of the object resulting from joining both meshes
  • Inverting the normals of the duplicate object

Stuff you didn’t try:

  • Duplicating the faces in edit mode (as I said) and flipping (not recalculating) normals after scaling -1

If you want help, have the decency to attempt the solution before writing it off.

-OR-
Just post the full file and I’ll fix it for you in ~15 seconds.

@dlax is right. Follow his steps in post #13.

I followed his steps and in under 3 minutes have a perfect mesh. I sculpted the letters MR 4 on multires level 4 to show. And you should do it yourself @uKer. It’s a great solution and takes minutes.

Question, @dlax, when you say “Merge additional verts which were missed by Remove Doubles” do you mean remove doubles again? or is there another command here?


oh, yes :slight_smile: that works perfectly fine, i never thought of deleting the duplicated half. nice work!